p PatchFirst

PatchFirst · Latest vulnerabilities

linux-hwe vulnerabilities · Page 4

Vulnerabilities published for linux-hwe in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 751

  1. CVE-2020-27066

    Medium · CVSS 6.7EPSS 0.16%Fix available

    CVE-2020-27066

    In xfrm6_tunnel_free_spi of net/ipv6/xfrm6_tunnel.c, there is a possible use after free due to improper locking. This could lead to local escalation of privilege with System execution privileges needed. User interaction is not needed for exploitation.Product: AndroidVersions: Android kernelAndroid ID: A-168043318

    • Update to 4.15.0-99.100~16.04.1
    Published Updated
  2. CVE-2020-0465

    Medium · CVSS 6.8EPSS 0.28%Fix available

    CVE-2020-0465

    In various methods of hid-multitouch.c, there is a possible out of bounds write due to a missing bounds check. This could lead to local escalation of privilege with no additional execution privileges needed. User interaction is not needed for exploitation.Product: AndroidVersions: Android kernelAndroid ID: A-162844689References: Upstream kernel

    • Update to 4.15.0-126.129~16.04.1
    Published Updated
  3. CVE-2020-0444

    High · CVSS 7.8EPSS 0.22%Fix available

    CVE-2020-0444

    In audit_free_lsm_field of auditfilter.c, there is a possible bad kfree due to a logic error in audit_data_to_entry. This could lead to local escalation of privilege with no additional execution privileges needed. User interaction is not needed for exploitation.Product: AndroidVersions: Android kernelAndroid ID: A-150693166References: Upstream kernel

    • Update to 4.15.0-99.100~16.04.1
    Published Updated
  4. CVE-2020-0466

    High · CVSS 7.8EPSS 0.28%Fix available

    CVE-2020-0466

    In do_epoll_ctl and ep_loop_check_proc of eventpoll.c, there is a possible use after free due to a logic error. This could lead to local escalation of privilege with no additional execution privileges needed. User interaction is not needed for exploitation.Product: AndroidVersions: Android kernelAndroid ID: A-147802478References: Upstream kernel

    • Update to 4.15.0-120.122~16.04.1
    Published Updated
  5. USN-4660-2

    Not ratedFix available

    linux, linux-aws, linux-aws-hwe, linux-azure, linux-azure-4.15, linux-gcp, linux-gcp-4.15, linux-gke-4.15, linux-hwe, linux-kvm, linux-oracle, linux-snapdragon regression

    USN-4660-1 fixed vulnerabilities in the Linux kernel. Unfortunately, that update introduced a regression in the software raid10 driver when used with fstrim that could lead to data corruption. This update fixes the problem. Original advisory details: It was discovered that a race condition existed in the perf subsystem of the Linux kernel, leading to a use-after-free vulnerability. An attacker with access to the perf subsystem could use this to cause a denial of service (system crash) or possibly execute arbitrary code. (CVE-2020-14351) It was discovered that the frame buffer implementation in the Linux kernel did not properly handle some

    • Update to 4.15.0-128.131~16.04.1
    Published Updated
  6. CVE-2020-27786

    High · CVSS 7.8EPSS 1.67%Fix available

    CVE-2020-27786

    A flaw was found in the Linux kernel’s implementation of MIDI, where an attacker with a local account and the permissions to issue ioctl commands to midi devices could trigger a use-after-free issue. A write to this specific memory while freed and before use causes the flow of execution to change and possibly allow for memory corruption or privilege escalation. The highest threat from this vulnerability is to confidentiality, integrity, as well as system availability.

    • Update to 4.15.0-107.108~16.04.1
    Published Updated
  7. CVE-2020-14351

    High · CVSS 7.8EPSS 0.31%Fix available

    CVE-2020-14351

    A flaw was found in the Linux kernel. A use-after-free memory flaw was found in the perf subsystem allowing a local attacker with permission to monitor perf events to corrupt memory and possibly escalate privileges. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability.

    • Update to 4.15.0-126.129~16.04.1
    Published Updated
  8. CVE-2020-14381

    High · CVSS 7.8EPSS 0.83%Fix available

    CVE-2020-14381

    A flaw was found in the Linux kernel’s futex implementation. This flaw allows a local attacker to corrupt system memory or escalate their privileges when creating a futex on a filesystem that is about to be unmounted. The highest threat from this vulnerability is to confidentiality, integrity, as well as system availability.

    • Update to 4.15.0-99.100~16.04.1
    Published Updated
  9. CVE-2020-14305

    High · CVSS 8.1EPSS 5.15%Fix available

    CVE-2020-14305

    An out-of-bounds memory write flaw was found in how the Linux kernel’s Voice Over IP H.323 connection tracking functionality handled connections on ipv6 port 1720. This flaw allows an unauthenticated remote user to crash the system, causing a denial of service. The highest threat from this vulnerability is to confidentiality, integrity, as well as system availability.

    • Update to 4.13.0-32.35~16.04.1
    Published Updated
  10. CVE-2020-25656

    Medium · CVSS 4.1EPSS 0.44%Fix available

    CVE-2020-25656

    A flaw was found in the Linux kernel. A use-after-free was found in the way the console subsystem was using ioctls KDGKBSENT and KDSKBSENT. A local user could use this flaw to get read memory access out of bounds. The highest threat from this vulnerability is to data confidentiality.

    • Update to 4.15.0-129.132~16.04.1
    Published Updated
  11. CVE-2020-29374

    Low · CVSS 3.6EPSS 0.4%Fix available

    CVE-2020-29374

    An issue was discovered in the Linux kernel before 5.7.3, related to mm/gup.c and mm/huge_memory.c. The get_user_pages (aka gup) implementation, when used for a copy-on-write page, does not properly consider the semantics of read operations and therefore can grant unintended write access, aka CID-17839856fd58.

    • Update to 4.15.0-136.140~16.04.1
    Published Updated
  12. CVE-2020-15437

    Medium · CVSS 4.4EPSS 0.43%Fix available

    CVE-2020-15437

    The Linux kernel before version 5.8 is vulnerable to a NULL pointer dereference in drivers/tty/serial/8250/8250_core.c:serial8250_isa_init_ports() that allows local users to cause a denial of service by using the p->serial_in pointer which uninitialized.

    • Update to 4.15.0-115.116~16.04.1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →