p PatchFirst

PatchFirst · Latest vulnerabilities

linux-kvm vulnerabilities · Page 11

Vulnerabilities published for linux-kvm in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 506

  1. CVE-2019-17075

    High · CVSS 7.5EPSS 6.46%Fix available

    CVE-2019-17075

    An issue was discovered in write_tpt_entry in drivers/infiniband/hw/cxgb4/mem.c in the Linux kernel through 5.3.2. The cxgb4 driver is directly calling dma_map_single (a DMA function) from a stack variable. This could allow an attacker to trigger a Denial of Service, exploitable if this driver is used on an architecture for which this stack/DMA interaction has security relevance.

    • Update to 4.4.0-1063.70
    Published Updated
  2. CVE-2019-14821

    High · CVSS 7.5EPSS 0.76%Fix available

    CVE-2019-14821

    An out-of-bounds access issue was found in the Linux kernel, all versions through 5.3, in the way Linux kernel's KVM hypervisor implements the Coalesced MMIO write operation. It operates on an MMIO ring buffer 'struct kvm_coalesced_mmio' object, wherein write indices 'ring->first' and 'ring->last' value could be supplied by a host user-space process. An unprivileged host user or process with access to '/dev/kvm' device could use this flaw to crash the host kernel, resulting in a denial of service or potentially escalating privileges on the system.

    • Update to 4.4.0-1060.67
    Published Updated
  3. CVE-2019-14835

    High · CVSS 7.2EPSS 0.62%Fix available

    CVE-2019-14835

    A buffer overflow flaw was found, in versions from 2.6.34 to 5.2.x, in the way Linux kernel's vhost functionality that translates virtqueue buffers to IOVs, logged the buffer descriptors during migration. A privileged guest user able to pass descriptors with invalid length to the host when migration is underway, could use this flaw to increase their privileges on the host.

    • Update to 4.4.0-1058.65
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →