p PatchFirst

PatchFirst · Latest vulnerabilities

linux-kvm vulnerabilities · Page 13

Vulnerabilities published for linux-kvm in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 506

  1. CVE-2017-18509

    High · CVSS 8.5EPSS 0.84%Fix available

    CVE-2017-18509

    An issue was discovered in net/ipv6/ip6mr.c in the Linux kernel before 4.11. By setting a specific socket option, an attacker can control a pointer in kernel land and cause an inet_csk_listen_stop general protection fault, or potentially execute arbitrary code under certain circumstances. The issue can be triggered as root (e.g., inside a default LXC container or with the CAP_NET_ADMIN capability) or after namespace unsharing. This occurs because sk_type and protocol are not checked in the appropriate part of the ip6_mroute_* functions. NOTE: this affects Linux distributions that use 4.9.x longterm kernels before 4.9.187.

    • Update to 4.4.0-1059.66
    Published Updated
  2. CVE-2019-14284

    Medium · CVSS 6.7EPSS 0.7%Fix available

    CVE-2019-14284

    In the Linux kernel before 5.2.3, drivers/block/floppy.c allows a denial of service by setup_format_params division-by-zero. Two consecutive ioctls can trigger the bug: the first one should set the drive geometry with .sect and .rate values that make F_SECT_PER_TRACK be zero. Next, the floppy format operation should be called. It can be triggered by an unprivileged local user even when a floppy disk has not been inserted. NOTE: QEMU creates the floppy device by default.

    • Update to 4.4.0-1056.63
    Published Updated
  3. CVE-2019-14283

    Medium · CVSS 6.8EPSS 0.73%Fix available

    CVE-2019-14283

    In the Linux kernel before 5.2.3, set_geometry in drivers/block/floppy.c does not validate the sect and head fields, as demonstrated by an integer overflow and out-of-bounds read. It can be triggered by an unprivileged local user when a floppy disk has been inserted. NOTE: QEMU creates the floppy device by default.

    • Update to 4.4.0-1056.63
    Published Updated
  4. CVE-2019-13272

    High · CVSS 7.8EPSS 52.2%In KEVPublic exploitFix available

    CVE-2019-13272

    In the Linux kernel before 5.1.17, ptrace_link in kernel/ptrace.c mishandles the recording of the credentials of a process that wants to create a ptrace relationship, which allows local users to obtain root access by leveraging certain scenarios with a parent-child process relationship, where a parent drops privileges and calls execve (potentially allowing control by an attacker). One contributing factor is an object lifetime issue (which can also cause a panic). Another contributing factor is incorrect marking of a ptrace relationship as privileged, which is exploitable through (for example) Polkit's pkexec helper with PTRACE_TRACEME. NOTE:

    • Update to 4.4.0-1054.61
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →