p PatchFirst

PatchFirst · Latest vulnerabilities

linux-oem vulnerabilities · Page 2

Vulnerabilities published for linux-oem in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 62

  1. CVE-2018-1000026

    High · CVSS 7.7EPSS 4.02%Fix available

    CVE-2018-1000026

    Linux Linux kernel version at least v4.8 onwards, probably well before contains a Insufficient input validation vulnerability in bnx2x network card driver that can result in DoS: Network card firmware assertion takes card off-line. This attack appear to be exploitable via An attacker on a must pass a very large, specially crafted packet to the bnx2x card. This can be done from an untrusted guest VM..

    • Update to 4.13.0-1022.24
    Published Updated
  2. USN-3548-2

    Not ratedFix available

    linux-hwe, linux-azure, linux-gcp, linux-oem vulnerability

    USN-3548-1 fixed vulnerabilities in the Linux kernel for Ubuntu 17.10. This update provides the corresponding updates for the Linux Hardware Enablement (HWE) kernel from Ubuntu 17.10 for Ubuntu 16.04 LTS. Jay Vosburgh discovered a logic error in the x86-64 syscall entry implementation in the Linux kernel, introduced as part of the mitigations for the Spectre vulnerability. A local attacker could use this to cause a denial of service or possibly execute arbitrary code.

    • Update to 4.13.0-1019.20
    Published Updated
  3. CVE-2017-15129

    Medium · CVSS 5.5EPSS 0.36%Fix available

    CVE-2017-15129

    A use-after-free vulnerability was found in network namespaces code affecting the Linux kernel before 4.14.11. The function get_net_ns_by_id() in net/core/net_namespace.c does not check for the net::count value after it has found a peer network in netns_ids idr, which could lead to double free and memory corruption. This vulnerability could allow an unprivileged local user to induce kernel memory corruption on the system, leading to a crash. Due to the nature of the flaw, privilege escalation cannot be fully ruled out, although it is thought to be unlikely.

    • Update to 4.13.0-1022.24
    Published Updated
  4. CVE-2017-17975

    Medium · CVSS 5.5EPSS 0.4%Fix available

    CVE-2017-17975

    Use-after-free in the usbtv_probe function in drivers/media/usb/usbtv/usbtv-core.c in the Linux kernel through 4.14.10 allows attackers to cause a denial of service (system crash) or possibly have unspecified other impact by triggering failure of audio registration, because a kfree of the usbtv data structure occurs during a usbtv_video_free call, but the usbtv_video_fail label's code attempts to both access and free this data structure.

    • Update to 4.13.0-1028.31
    Published Updated
  5. CVE-2017-17862

    Medium · CVSS 5.5EPSS 0.44%Fix available

    CVE-2017-17862

    kernel/bpf/verifier.c in the Linux kernel through 4.14.8 ignores unreachable code, even though it would still be processed by JIT compilers. This behavior, also considered an improper branch-pruning logic issue, could possibly be used by local users for denial of service.

    • Update to 4.13.0-1015.16
    Published Updated
  6. CVE-2017-17807

    Low · CVSS 3.3EPSS 0.44%Fix available

    CVE-2017-17807

    The KEYS subsystem in the Linux kernel before 4.14.6 omitted an access-control check when adding a key to the current task's "default request-key keyring" via the request_key() system call, allowing a local user to use a sequence of crafted system calls to add keys to a keyring with only Search permission (not Write permission) to that keyring, related to construct_get_dest_keyring() in security/keys/request_key.c.

    • Update to 4.13.0-1022.24
    Published Updated
  7. CVE-2017-17806

    High · CVSS 7.8EPSS 0.56%Fix available

    CVE-2017-17806

    The HMAC implementation (crypto/hmac.c) in the Linux kernel before 4.14.8 does not validate that the underlying cryptographic hash algorithm is unkeyed, allowing a local attacker able to use the AF_ALG-based hash interface (CONFIG_CRYPTO_USER_API_HASH) and the SHA-3 hash algorithm (CONFIG_CRYPTO_SHA3) to cause a kernel stack buffer overflow by executing a crafted sequence of system calls that encounter a missing SHA-3 initialization.

    • Update to 4.13.0-1022.24
    Published Updated
  8. CVE-2017-17805

    High · CVSS 7.8EPSS 0.44%Fix available

    CVE-2017-17805

    The Salsa20 encryption algorithm in the Linux kernel before 4.14.8 does not correctly handle zero-length inputs, allowing a local attacker able to use the AF_ALG-based skcipher interface (CONFIG_CRYPTO_USER_API_SKCIPHER) to cause a denial of service (uninitialized-memory free and kernel crash) or have unspecified other impact by executing a crafted sequence of system calls that use the blkcipher_walk API. Both the generic implementation (crypto/salsa20_generic.c) and x86 implementation (arch/x86/crypto/salsa20_glue.c) of Salsa20 were vulnerable.

    • Update to 4.13.0-1022.24
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →