p PatchFirst

PatchFirst · Latest vulnerabilities

linux-snapdragon vulnerabilities · Page 19

Vulnerabilities published for linux-snapdragon in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 674

  1. CVE-2018-5848

    High · CVSS 7.8EPSS 0.39%Fix available

    CVE-2018-5848

    In the function wmi_set_ie(), the length validation code does not handle unsigned integer overflow properly. As a result, a large value of the 'ie_len' argument can cause a buffer overflow in all Android releases from CAF (Android for MSM, Firefox OS for MSM, QRD Android) using the Linux Kernel.

    • Update to 4.4.0-1108.113
    Published Updated
  2. CVE-2018-5814

    High · CVSS 7EPSS 0.37%Fix available

    CVE-2018-5814

    In the Linux Kernel before version 4.16.11, 4.14.43, 4.9.102, and 4.4.133, multiple race condition errors when handling probe, disconnect, and rebind operations can be exploited to trigger a use-after-free condition or a NULL pointer dereference by sending multiple USB over IP packets.

    • Update to 4.4.0-1095.100
    Published Updated
  3. CVE-2018-12233

    High · CVSS 7.8EPSS 2.4%Fix available

    CVE-2018-12233

    In the ea_get function in fs/jfs/xattr.c in the Linux kernel through 4.17.1, a memory corruption bug in JFS can be triggered by calling setxattr twice with two different extended attribute names on the same file. This vulnerability can be triggered by an unprivileged user with the ability to create files and execute programs. A kmalloc call is incorrect, leading to slab-out-of-bounds in jfs_xattr.

    • Update to 4.4.0-1099.104
    Published Updated
  4. CVE-2018-1000199

    Medium · CVSS 5.5EPSS 1.21%Fix available

    CVE-2018-1000199

    The Linux Kernel version 3.18 contains a dangerous feature vulnerability in modify_user_hw_breakpoint() that can result in crash and possibly memory corruption. This attack appear to be exploitable via local code execution and the ability to use ptrace. This vulnerability appears to have been fixed in git commit f67b15037a7a50c57f72e69a6d59941ad90a0f0f.

    • Update to 4.4.0-1092.97
    Published Updated
  5. CVE-2018-3639

    Medium · CVSS 5.5EPSS 60.63%Public exploitFix available

    CVE-2018-3639

    Systems with microprocessors utilizing speculative execution and speculative execution of memory reads before the addresses of all prior memory writes are known may allow unauthorized disclosure of information to an attacker with local user access via a side-channel analysis, aka Speculative Store Bypass (SSB), Variant 4.

    • Update to 4.4.0-1094.99
    Published Updated
  6. CVE-2018-8781

    High · CVSS 7.8EPSS 0.49%Fix available

    CVE-2018-8781

    The udl_fb_mmap function in drivers/gpu/drm/udl/udl_fb.c at the Linux kernel version 3.4 and up to and including 4.15 has an integer-overflow vulnerability allowing local users with access to the udldrmfb driver to obtain full read and write permissions on kernel physical pages, resulting in a code execution in kernel space.

    • Update to 4.4.0-1093.98
    Published Updated
  7. CVE-2018-10021

    Medium · CVSS 5.5EPSS 0.45%Fix available

    CVE-2018-10021

    drivers/scsi/libsas/sas_scsi_host.c in the Linux kernel before 4.16 allows local users to cause a denial of service (ata qc leak) by triggering certain failure conditions. NOTE: a third party disputes the relevance of this report because the failure can only occur for physically proximate attackers who unplug SAS Host Bus Adapter cables

    • Update to 4.4.0-1095.100
    Published Updated
  8. CVE-2018-1092

    Medium · CVSS 5.5EPSS 1.85%Fix available

    CVE-2018-1092

    The ext4_iget function in fs/ext4/inode.c in the Linux kernel through 4.15.15 mishandles the case of a root directory with a zero i_links_count, which allows attackers to cause a denial of service (ext4_process_freed_data NULL pointer dereference and OOPS) via a crafted ext4 image.

    • Update to 4.4.0-1094.99
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →