p PatchFirst

PatchFirst · Latest vulnerabilities

linux vulnerabilities · Page 21

Vulnerabilities published for linux in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 713

  1. CVE-2018-8781

    High · CVSS 7.8EPSS 0.49%Fix available

    CVE-2018-8781

    The udl_fb_mmap function in drivers/gpu/drm/udl/udl_fb.c at the Linux kernel version 3.4 and up to and including 4.15 has an integer-overflow vulnerability allowing local users with access to the udldrmfb driver to obtain full read and write permissions on kernel physical pages, resulting in a code execution in kernel space.

    • Update to 4.4.0-127.153
    Published Updated
  2. CVE-2018-10021

    Medium · CVSS 5.5EPSS 0.45%Fix available

    CVE-2018-10021

    drivers/scsi/libsas/sas_scsi_host.c in the Linux kernel before 4.16 allows local users to cause a denial of service (ata qc leak) by triggering certain failure conditions. NOTE: a third party disputes the relevance of this report because the failure can only occur for physically proximate attackers who unplug SAS Host Bus Adapter cables

    • Update to 4.4.0-130.156
    Published Updated
  3. CVE-2018-1092

    Medium · CVSS 5.5EPSS 1.85%Fix available

    CVE-2018-1092

    The ext4_iget function in fs/ext4/inode.c in the Linux kernel through 4.15.15 mishandles the case of a root directory with a zero i_links_count, which allows attackers to cause a denial of service (ext4_process_freed_data NULL pointer dereference and OOPS) via a crafted ext4 image.

    • Update to 4.4.0-128.154
    Published Updated
  4. CVE-2017-18255

    High · CVSS 7.8EPSS 0.39%Fix available

    CVE-2017-18255

    The perf_cpu_time_max_percent_handler function in kernel/events/core.c in the Linux kernel before 4.11 allows local users to cause a denial of service (integer overflow) or possibly have unspecified other impact via a large value, as demonstrated by an incorrect sample-rate calculation.

    • Update to 4.4.0-130.156
    Published Updated
  5. CVE-2018-8822

    High · CVSS 7.8EPSS 0.53%Fix available

    CVE-2018-8822

    Incorrect buffer length handling in the ncp_read_kernel function in fs/ncpfs/ncplib_kernel.c in the Linux kernel through 4.15.11, and in drivers/staging/ncpfs/ncplib_kernel.c in the Linux kernel 4.16-rc through 4.16-rc6, could be exploited by malicious NCPFS servers to crash the kernel or execute code.

    • Update to 4.4.0-127.153
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →