p PatchFirst

PatchFirst · Latest vulnerabilities

apache2 vulnerabilities · Page 3

Vulnerabilities published for apache2 in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 53

  1. CVE-2019-0211

    High · CVSS 7.8EPSS 65%In KEVPublic exploitFix available

    CVE-2019-0211

    In Apache HTTP Server 2.4 releases 2.4.17 to 2.4.38, with MPM event, worker or prefork, code executing in less-privileged child processes or threads (including scripts executed by an in-process scripting interpreter) could execute arbitrary code with the privileges of the parent process (usually root) by manipulating the scoreboard. Non-Unix systems are not affected.

    • Update to 2.4.29-1ubuntu4.6
    Published Updated
  2. CVE-2018-17189

    Medium · CVSS 5.3EPSS 20.07%Fix available

    CVE-2018-17189

    In Apache HTTP server versions 2.4.37 and prior, by sending request bodies in a slow loris way to plain resources, the h2 stream for that request unnecessarily occupied a server thread cleaning up that incoming data. This affects only HTTP/2 (mod_http2) connections.

    • Update to 2.4.29-1ubuntu4.6
    Published Updated
  3. CVE-2018-11763

    Medium · CVSS 5.9EPSS 50.85%Fix available

    CVE-2018-11763

    In Apache HTTP Server 2.4.17 to 2.4.34, by sending continuous, large SETTINGS frames a client can occupy a connection, server thread and CPU time without any connection timeout coming to effect. This affects only HTTP/2 connections. A possible mitigation is to not enable the h2 protocol.

    • Update to 2.4.29-1ubuntu4.4
    Published Updated
  4. CVE-2018-1312

    Critical · CVSS 9.8EPSS 15.72%Fix available

    CVE-2018-1312

    In Apache httpd 2.2.0 to 2.4.29, when generating an HTTP Digest authentication challenge, the nonce sent to prevent reply attacks was not correctly generated using a pseudo-random seed. In a cluster of servers using a common Digest authentication configuration, HTTP requests could be replayed across servers by an attacker without detection.

    • Update to 2.4.29-1ubuntu4.1
    Published Updated
  5. CVE-2018-1303

    High · CVSS 7.5EPSS 69.8%Fix available

    CVE-2018-1303

    A specially crafted HTTP request header could have crashed the Apache HTTP Server prior to version 2.4.30 due to an out of bound read while preparing data to be cached in shared memory. It could be used as a Denial of Service attack against users of mod_cache_socache. The vulnerability is considered as low risk since mod_cache_socache is not widely used, mod_cache_disk is not concerned by this vulnerability.

    • Update to 2.4.29-1ubuntu4.1
    Published Updated
  6. CVE-2018-1302

    Medium · CVSS 5.9EPSS 12.88%Fix available

    CVE-2018-1302

    When an HTTP/2 stream was destroyed after being handled, the Apache HTTP Server prior to version 2.4.30 could have written a NULL pointer potentially to an already freed memory. The memory pools maintained by the server make this vulnerability hard to trigger in usual configurations, the reporter and the team could not reproduce it outside debug builds, so it is classified as low risk.

    • Update to 2.4.29-1ubuntu4.4
    Published Updated
  7. CVE-2018-1301

    Medium · CVSS 5.9EPSS 14.99%Fix available

    CVE-2018-1301

    A specially crafted request could have crashed the Apache HTTP Server prior to version 2.4.30, due to an out of bound access after a size limit is reached by reading the HTTP header. This vulnerability is considered very hard if not impossible to trigger in non-debug mode (both log and build level), so it is classified as low risk for common server usage.

    • Update to 2.4.29-1ubuntu4.1
    Published Updated
  8. CVE-2018-1283

    Medium · CVSS 5.3EPSS 9.74%Fix available

    CVE-2018-1283

    In Apache httpd 2.4.0 to 2.4.29, when mod_session is configured to forward its session data to CGI applications (SessionEnv on, not the default), a remote user may influence their content by using a "Session" header. This comes from the "HTTP_SESSION" variable name used by mod_session to forward its data to CGIs, since the prefix "HTTP_" is also used by the Apache HTTP Server to pass HTTP header fields, per CGI specifications.

    • Update to 2.4.29-1ubuntu4.1
    Published Updated
  9. CVE-2017-15715

    High · CVSS 8.1EPSS 85.45%Public exploitFix available

    CVE-2017-15715

    In Apache httpd 2.4.0 to 2.4.29, the expression specified in <FilesMatch> could match '$' to a newline character in a malicious filename, rather than matching only the end of the filename. This could be exploited in environments where uploads of some files are are externally blocked, but only by matching the trailing portion of the filename.

    • Update to 2.4.29-1ubuntu4.1
    Published Updated
  10. CVE-2017-15710

    High · CVSS 7.5EPSS 17.08%Fix available

    CVE-2017-15710

    In Apache httpd 2.0.23 to 2.0.65, 2.2.0 to 2.2.34, and 2.4.0 to 2.4.29, mod_authnz_ldap, if configured with AuthLDAPCharsetConfig, uses the Accept-Language header value to lookup the right charset encoding when verifying the user's credentials. If the header value is not present in the charset conversion table, a fallback mechanism is used to truncate it to a two characters value to allow a quick retry (for example, 'en-US' is truncated to 'en'). A header value of less than two characters forces an out of bound write of one NUL byte to a memory location that is not part of the string. In the worst case, quite unlikely, the process would crash

    • Update to 2.4.29-1ubuntu4.1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →