p PatchFirst

PatchFirst · Latest vulnerabilities

linux-aws vulnerabilities · Page 55

Vulnerabilities published for linux-aws in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 1606

  1. CVE-2021-39656

    Medium · CVSS 6.7EPSS 0.12%Fix available

    CVE-2021-39656

    In __configfs_open_file of file.c, there is a possible use-after-free due to improper locking. This could lead to local escalation of privilege in the kernel with System execution privileges needed. User interaction is not needed for exploitation.Product: AndroidVersions: Android kernelAndroid ID: A-174049066References: Upstream kernel

    • Update to 4.15.0-1103.110
    Published Updated
  2. CVE-2021-39648

    Medium · CVSS 4.1EPSS 0.17%Fix available

    CVE-2021-39648

    In gadget_dev_desc_UDC_show of configfs.c, there is a possible disclosure of kernel heap memory due to a race condition. This could lead to local information disclosure with System execution privileges needed. User interaction is not needed for exploitation.Product: AndroidVersions: Android kernelAndroid ID: A-160822094References: Upstream kernel

    • Update to 4.15.0-1095.102
    Published Updated
  3. CVE-2021-39636

    Medium · CVSS 4.4EPSS 0.23%Fix available

    CVE-2021-39636

    In do_ipt_get_ctl and do_ipt_set_ctl of ip_tables.c, there is a possible way to leak kernel information due to uninitialized data. This could lead to local information disclosure with system execution privileges needed. User interaction is not needed for exploitation.Product: AndroidVersions: Android kernelAndroid ID: A-120612905References: Upstream kernel

    • Update to 4.15.0-1011.11
    Published Updated
  4. CVE-2021-1048

    High · CVSS 7.8EPSS 1.06%In KEVFix available

    CVE-2021-1048

    In ep_loop_check_proc of eventpoll.c, there is a possible way to corrupt memory due to a use after free. This could lead to local escalation of privilege with no additional execution privileges needed. User interaction is not needed for exploitation.Product: AndroidVersions: Android kernelAndroid ID: A-204573007References: Upstream kernel

    • Update to 4.15.0-1088.93
    Published Updated
  5. CVE-2021-0920

    Medium · CVSS 6.4EPSS 0.87%In KEVFix available

    CVE-2021-0920

    In unix_scm_to_skb of af_unix.c, there is a possible use after free bug due to a race condition. This could lead to local escalation of privilege with System execution privileges needed. User interaction is not needed for exploitation.Product: AndroidVersions: Android kernelAndroid ID: A-196926917References: Upstream kernel

    • Update to 4.15.0-1112.119
    Published Updated
  6. CVE-2018-25020

    High · CVSS 7.8EPSS 0.53%Fix available

    CVE-2018-25020

    The BPF subsystem in the Linux kernel before 4.17 mishandles situations with a long jump over an instruction sequence where inner instructions require substantial expansions into multiple BPF instructions, leading to an overflow. This affects kernel/bpf/core.c and net/core/filter.c.

    • Update to 4.15.0-1118.125
    Published Updated
  7. CVE-2021-0941

    Medium · CVSS 6.7EPSS 0.17%Fix available

    CVE-2021-0941

    In bpf_skb_change_head of filter.c, there is a possible out of bounds read due to a use after free. This could lead to local escalation of privilege with System execution privileges needed. User interaction is not needed for exploitation.Product: AndroidVersions: Android kernelAndroid ID: A-154177719References: Upstream kernel

    • Update to 4.15.0-1103.110
    Published Updated
  8. CVE-2021-3542

    Not ratedFix available

    UBUNTU-CVE-2021-3542

    Rejected reason: DO NOT USE THIS CANDIDATE NUMBER. ConsultIDs: CVE-2021-42739. Reason: This candidate is a reservation duplicate of CVE-2021-42739. Notes: All CVE users should reference CVE-2021-42739 instead of this candidate. All references and descriptions in this candidate have been removed to prevent accidental usage

    • Update to 4.15.0-1119.127
    Published Updated
  9. CVE-2021-3653

    High · CVSS 8.8EPSS 0.45%Fix available

    CVE-2021-3653

    A flaw was found in the KVM's AMD code for supporting SVM nested virtualization. The flaw occurs when processing the VMCB (virtual machine control block) provided by the L1 guest to spawn/handle a nested guest (L2). Due to improper validation of the "int_ctl" field, this issue could allow a malicious L1 to enable AVIC support (Advanced Virtual Interrupt Controller) for the L2 guest. As a result, the L2 guest would be allowed to read/write physical pages of the host, resulting in a crash of the entire system, leak of sensitive data or potential guest-to-host escape. This flaw affects Linux kernel versions prior to 5.14-rc7.

    • Update to 4.15.0-1111.118
    Published Updated
  10. CVE-2021-20317

    Medium · CVSS 4.4EPSS 0.38%Fix available

    CVE-2021-20317

    A flaw was found in the Linux kernel. A corrupted timer tree caused the task wakeup to be missing in the timerqueue_add function in lib/timerqueue.c. This flaw allows a local attacker with special user privileges to cause a denial of service, slowing and eventually stopping the system while running OSP.

    • Update to 4.15.0-1118.125
    Published Updated
  11. CVE-2021-21781

    Medium · CVSS 4EPSS 0.5%Fix available

    CVE-2021-21781

    An information disclosure vulnerability exists in the ARM SIGPAGE functionality of Linux Kernel v5.4.66 and v5.4.54. The latest version (5.11-rc4) seems to still be vulnerable. A userland application can read the contents of the sigpage, which can leak kernel memory contents. An attacker can read a process’s memory at a specific offset to trigger this vulnerability. This was fixed in kernel releases: 4.14.222 4.19.177 5.4.99 5.10.17 5.11

    • Update to 4.15.0-1102.109
    Published Updated
  12. CVE-2021-3573

    Medium · CVSS 6.4EPSS 0.37%Fix available

    CVE-2021-3573

    A use-after-free in function hci_sock_bound_ioctl() of the Linux kernel HCI subsystem was found in the way user calls ioct HCIUNBLOCKADDR or other way triggers race condition of the call hci_unregister_dev() together with one of the calls hci_sock_blacklist_add(), hci_sock_blacklist_del(), hci_get_conn_info(), hci_get_auth_info(). A privileged local user could use this flaw to crash the system or escalate their privileges on the system. This flaw affects the Linux kernel versions prior to 5.13-rc5.

    • Update to 4.15.0-1110.117
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →