p PatchFirst

PatchFirst · Latest vulnerabilities

linux-azure-5.4 vulnerabilities · Page 71

Vulnerabilities published for linux-azure-5.4 in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 1756

  1. CVE-2022-20423

    Medium · CVSS 4.6EPSS 0.27%Fix available

    CVE-2022-20423

    In rndis_set_response of rndis.c, there is a possible out of bounds write due to an integer overflow. This could lead to local escalation of privilege if a malicious USB device is attached with no additional execution privileges needed. User interaction is not needed for exploitation.Product: AndroidVersions: Android kernelAndroid ID: A-239842288References: Upstream kernel

    • Update to 5.4.0-1083.87~18.04.1
    Published Updated
  2. CVE-2022-20422

    High · CVSS 7EPSS 0.19%Fix available

    CVE-2022-20422

    In emulation_proc_handler of armv8_deprecated.c, there is a possible way to corrupt memory due to a race condition. This could lead to local escalation of privilege with no additional execution privileges needed. User interaction is not needed for exploitation.Product: AndroidVersions: Android kernelAndroid ID: A-237540956References: Upstream kernel

    • Update to 5.4.0-1095.101~18.04.1
    Published Updated
  3. CVE-2022-20421

    High · CVSS 7.8EPSS 0.62%Fix available

    CVE-2022-20421

    In binder_inc_ref_for_node of binder.c, there is a possible way to corrupt memory due to a use after free. This could lead to local escalation of privilege with no additional execution privileges needed. User interaction is not needed for exploitation.Product: AndroidVersions: Android kernelAndroid ID: A-239630375References: Upstream kernel

    • Update to 5.4.0-1100.106~18.04.1
    Published Updated
  4. CVE-2022-3435

    Medium · CVSS 4.3EPSS 5.18%Fix available

    Linux Kernel IPv4 fib_semantics.c fib_nh_match out-of-bounds

    A vulnerability classified as problematic has been found in Linux Kernel. This affects the function fib_nh_match of the file net/ipv4/fib_semantics.c of the component IPv4 Handler. The manipulation leads to out-of-bounds read. It is possible to initiate the attack remotely. It is recommended to apply a patch to fix this issue. The identifier VDB-210357 was assigned to this vulnerability.

    • Update to 5.4.0-1104.110~18.04.1
    Published Updated
  5. CVE-2022-41849

    Medium · CVSS 4.2EPSS 0.35%Fix available

    CVE-2022-41849

    drivers/video/fbdev/smscufx.c in the Linux kernel through 5.19.12 has a race condition and resultant use-after-free if a physically proximate attacker removes a USB device while calling open(), aka a race condition between ufx_ops_open and ufx_usb_disconnect.

    • Update to 5.4.0-1103.109~18.04.1
    Published Updated
  6. CVE-2022-3303

    Medium · CVSS 4.7EPSS 0.32%Fix available

    CVE-2022-3303

    A race condition flaw was found in the Linux kernel sound subsystem due to improper locking. It could lead to a NULL pointer dereference while handling the SNDCTL_DSP_SYNC ioctl. A privileged local user (root or member of the audio group) could use this flaw to crash the system, resulting in a denial of service condition

    • Update to 5.4.0-1100.106~18.04.1
    Published Updated
  7. CVE-2022-3176

    High · CVSS 7.8EPSS 0.3%Fix available

    Use-after-free in io_uring in Linux Kernel

    There exists a use-after-free in io_uring in the Linux kernel. Signalfd_poll() and binder_poll() use a waitqueue whose lifetime is the current task. It will send a POLLFREE notification to all waiters before the queue is freed. Unfortunately, the io_uring poll doesn't handle POLLFREE. This allows a use-after-free to occur if a signalfd or binder fd is polled with io_uring poll, and the waitqueue gets freed. We recommend upgrading past commit fc78b2fc21f10c4c9c4d5d659a685710ffa63659

    • Update to 5.4.0-1094.100~18.04.1
    Published Updated
  8. CVE-2022-2977

    High · CVSS 7.8EPSS 0.24%Fix available

    CVE-2022-2977

    A flaw was found in the Linux kernel implementation of proxied virtualized TPM devices. On a system where virtualized TPM devices are configured (this is not the default) a local attacker can create a use-after-free and create a situation where it may be possible to escalate privileges on the system.

    • Update to 5.4.0-1083.87~18.04.1
    Published Updated
  9. CVE-2022-36280

    Medium · CVSS 6.3EPSS 0.78%Fix available

    There is an out-of-bounds write vulnerability in vmwgfx driver

    An out-of-bounds(OOB) memory access vulnerability was found in vmwgfx driver in drivers/gpu/vmxgfx/vmxgfx_kms.c in GPU component in the Linux kernel with device file '/dev/dri/renderD128 (or Dxxx)'. This flaw allows a local attacker with a user account on the system to gain privilege, causing a denial of service(DoS).

    • Update to 5.4.0-1104.110~18.04.1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →