p PatchFirst

PatchFirst · Latest vulnerabilities

linux-gcp-5.4 vulnerabilities · Page 87

Vulnerabilities published for linux-gcp-5.4 in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 1756

  1. CVE-2020-0423

    High · CVSS 7.8EPSS 0.51%Fix available

    CVE-2020-0423

    In binder_release_work of binder.c, there is a possible use-after-free due to improper locking. This could lead to local escalation of privilege in the kernel with no additional execution privileges needed. User interaction is not needed for exploitation.Product: AndroidVersions: Android kernelAndroid ID: A-161151868References: N/A

    • Update to 5.4.0-1030.32~18.04.1
    Published Updated
  2. CVE-2020-25645

    High · CVSS 7.5EPSS 2.43%Fix available

    CVE-2020-25645

    A flaw was found in the Linux kernel in versions before 5.9-rc7. Traffic between two Geneve endpoints may be unencrypted when IPsec is configured to encrypt traffic for the specific UDP port used by the GENEVE tunnel allowing anyone between the two endpoints to read the traffic unencrypted. The main threat from this vulnerability is to data confidentiality.

    • Update to 5.4.0-1030.32~18.04.1
    Published Updated
  3. CVE-2020-25641

    Medium · CVSS 5.5EPSS 0.39%Fix available

    CVE-2020-25641

    A flaw was found in the Linux kernel's implementation of biovecs in versions before 5.9-rc7. A zero-length biovec request issued by the block subsystem could cause the kernel to enter an infinite loop, causing a denial of service. This flaw allows a local attacker with basic privileges to issue requests to a block device, resulting in a denial of service. The highest threat from this vulnerability is to system availability.

    • Update to 5.4.0-1028.29~18.04.1
    Published Updated
  4. CVE-2020-25643

    High · CVSS 7.2EPSS 3.29%Fix available

    CVE-2020-25643

    A flaw was found in the HDLC_PPP module of the Linux kernel in versions before 5.9-rc7. Memory corruption and a read overflow is caused by improper input validation in the ppp_cp_parse_cr function which can cause the system to crash or cause a denial of service. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability.

    • Update to 5.4.0-1030.32~18.04.1
    Published Updated
  5. CVE-2020-14390

    Medium · CVSS 5.6EPSS 0.35%Fix available

    CVE-2020-14390

    A flaw was found in the Linux kernel in versions before 5.9-rc6. When changing screen size, an out-of-bounds memory write can occur leading to memory corruption or a denial of service. Due to the nature of the flaw, privilege escalation cannot be fully ruled out.

    • Update to 5.4.0-1030.32~18.04.1
    Published Updated
  6. CVE-2020-10781

    Medium · CVSS 5.5EPSS 0.31%Fix available

    CVE-2020-10781

    A flaw was found in the Linux Kernel before 5.8-rc6 in the ZRAM kernel module, where a user with a local account and the ability to read the /sys/class/zram-control/hot_add file can create ZRAM device nodes in the /dev/ directory. This read allocates kernel memory and is not accounted for a user that triggers the creation of that ZRAM device. With this vulnerability, continually reading the device may consume a large amount of system memory and cause the Out-of-Memory (OOM) killer to activate and terminate random userspace processes, possibly making the system inoperable.

    • Update to 5.4.0-1022.22~18.04.1
    Published Updated
  7. CVE-2020-10768

    Medium · CVSS 5.5EPSS 0.4%Fix available

    CVE-2020-10768

    A flaw was found in the Linux Kernel before 5.8-rc1 in the prctl() function, where it can be used to enable indirect branch speculation after it has been disabled. This call incorrectly reports it as being 'force disabled' when it is not and opens the system to Spectre v2 attacks. The highest threat from this vulnerability is to confidentiality.

    • Update to 5.4.0-1022.22~18.04.1
    Published Updated
  8. CVE-2020-10767

    Medium · CVSS 5.5EPSS 0.38%Fix available

    CVE-2020-10767

    A flaw was found in the Linux kernel before 5.8-rc1 in the implementation of the Enhanced IBPB (Indirect Branch Prediction Barrier). The IBPB mitigation will be disabled when STIBP is not available or when the Enhanced Indirect Branch Restricted Speculation (IBRS) is available. This flaw allows a local attacker to perform a Spectre V2 style attack when this configuration is active. The highest threat from this vulnerability is to confidentiality.

    • Update to 5.4.0-1022.22~18.04.1
    Published Updated
  9. CVE-2020-10766

    Medium · CVSS 5.5EPSS 0.46%Fix available

    CVE-2020-10766

    A logic bug flaw was found in Linux kernel before 5.8-rc1 in the implementation of SSBD. A bug in the logic handling allows an attacker with a local account to disable SSBD protection during a context switch when additional speculative execution mitigations are in place. This issue was introduced when the per task/process conditional STIPB switching was added on top of the existing SSBD switching. The highest threat from this vulnerability is to confidentiality.

    • Update to 5.4.0-1022.22~18.04.1
    Published Updated
  10. CVE-2020-14385

    Medium · CVSS 5.5EPSS 0.42%Fix available

    CVE-2020-14385

    A flaw was found in the Linux kernel before 5.9-rc4. A failure of the file system metadata validator in XFS can cause an inode with a valid, user-creatable extended attribute to be flagged as corrupt. This can lead to the filesystem being shutdown, or otherwise rendered inaccessible until it is remounted, leading to a denial of service. The highest threat from this vulnerability is to system availability.

    • Update to 5.4.0-1028.29~18.04.1
    Published Updated
  11. CVE-2020-14314

    Medium · CVSS 5.5EPSS 0.37%Fix available

    CVE-2020-14314

    A memory out-of-bounds read flaw was found in the Linux kernel before 5.9-rc2 with the ext3/ext4 file system, in the way it accesses a directory with broken indexing. This flaw allows a local user to crash the system if the directory exists. The highest threat from this vulnerability is to system availability.

    • Update to 5.4.0-1028.29~18.04.1
    Published Updated
  12. CVE-2020-25211

    Medium · CVSS 6EPSS 0.57%Fix available

    CVE-2020-25211

    In the Linux kernel through 5.8.7, local attackers able to inject conntrack netlink configuration could overflow a local buffer, causing crashes or triggering use of incorrect protocol numbers in ctnetlink_parse_tuple_filter in net/netfilter/nf_conntrack_netlink.c, aka CID-1cc5ef91d2ff.

    • Update to 5.4.0-1030.32~18.04.1
    Published Updated
  13. CVE-2020-3702

    Medium · CVSS 6.5EPSS 0.33%Fix available

    CVE-2020-3702

    u'Specifically timed and handcrafted traffic can cause internal errors in a WLAN device that lead to improper layer 2 Wi-Fi encryption with a consequent possibility of information disclosure over the air for a discrete set of traffic' in Snapdragon Auto, Snapdragon Compute, Snapdragon Connectivity, Snapdragon Consumer IOT, Snapdragon Industrial IOT, Snapdragon Mobile, Snapdragon Voice & Music, Snapdragon Wearables, Snapdragon Wired Infrastructure and Networking in APQ8053, IPQ4019, IPQ8064, MSM8909W, MSM8996AU, QCA9531, QCN5502, QCS405, SDX20, SM6150, SM7150

    • Update to 5.4.0-1056.60~18.04.1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →