p PatchFirst

PatchFirst · Latest vulnerabilities

linux-hwe-5.4 vulnerabilities · Page 86

Vulnerabilities published for linux-hwe-5.4 in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 1770

  1. CVE-2020-27777

    Medium · CVSS 6.7EPSS 0.48%Fix available

    CVE-2020-27777

    A flaw was found in the way RTAS handled memory accesses in userspace to kernel communication. On a locked down (usually due to Secure Boot) guest system running on top of PowerVM or KVM hypervisors (pseries platform) a root like local user could use this flaw to further increase their privileges to that of a running kernel.

    • Update to 5.4.0-59.65~18.04.1
    Published Updated
  2. CVE-2020-29568

    Medium · CVSS 6.5EPSS 0.36%Fix available

    CVE-2020-29568

    An issue was discovered in Xen through 4.14.x. Some OSes (such as Linux, FreeBSD, and NetBSD) are processing watch events using a single thread. If the events are received faster than the thread is able to handle, they will get queued. As the queue is unbounded, a guest may be able to trigger an OOM in the backend. All systems with a FreeBSD, Linux, or NetBSD (any version) dom0 are vulnerable.

    • Update to 5.4.0-66.74~18.04.2
    Published Updated
  3. CVE-2020-0465

    Medium · CVSS 6.8EPSS 0.28%Fix available

    CVE-2020-0465

    In various methods of hid-multitouch.c, there is a possible out of bounds write due to a missing bounds check. This could lead to local escalation of privilege with no additional execution privileges needed. User interaction is not needed for exploitation.Product: AndroidVersions: Android kernelAndroid ID: A-162844689References: Upstream kernel

    • Update to 5.4.0-51.56~18.04.1
    Published Updated
  4. CVE-2020-0466

    High · CVSS 7.8EPSS 0.28%Fix available

    CVE-2020-0466

    In do_epoll_ctl and ep_loop_check_proc of eventpoll.c, there is a possible use after free due to a logic error. This could lead to local escalation of privilege with no additional execution privileges needed. User interaction is not needed for exploitation.Product: AndroidVersions: Android kernelAndroid ID: A-147802478References: Upstream kernel

    • Update to 5.4.0-51.56~18.04.1
    Published Updated
  5. USN-4658-2

    Not ratedFix available

    linux, linux-aws, linux-aws-5.4, linux-azure, linux-azure-5.4, linux-gcp, linux-gcp-5.4, linux-hwe-5.4, linux-kvm, linux-oracle, linux-oracle-5.4, linux-raspi, linux-raspi-5.4 regression

    USN-4658-1 fixed vulnerabilities in the Linux kernel. Unfortunately, that update introduced a regression in the software raid10 driver when used with fstrim that could lead to data corruption. This update fixes the problem. Original advisory details: It was discovered that a race condition existed in the binder IPC implementation in the Linux kernel, leading to a use-after-free vulnerability. A local attacker could use this to cause a denial of service (system crash) or possibly execute arbitrary code. (CVE-2020-0423) Daniele Antonioli, Nils Ole Tippenhauer, and Kasper Rasmussen discovered that legacy pairing and secure-connections pairing

    • Update to 5.4.0-58.64~18.04.1
    Published Updated
  6. CVE-2020-27786

    High · CVSS 7.8EPSS 1.67%Fix available

    CVE-2020-27786

    A flaw was found in the Linux kernel’s implementation of MIDI, where an attacker with a local account and the permissions to issue ioctl commands to midi devices could trigger a use-after-free issue. A write to this specific memory while freed and before use causes the flow of execution to change and possibly allow for memory corruption or privilege escalation. The highest threat from this vulnerability is to confidentiality, integrity, as well as system availability.

    • Update to 5.4.0-40.44~18.04.1
    Published Updated
  7. CVE-2020-14351

    High · CVSS 7.8EPSS 0.31%Fix available

    CVE-2020-14351

    A flaw was found in the Linux kernel. A use-after-free memory flaw was found in the perf subsystem allowing a local attacker with permission to monitor perf events to corrupt memory and possibly escalate privileges. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability.

    • Update to 5.4.0-56.62~18.04.1
    Published Updated
  8. CVE-2020-25656

    Medium · CVSS 4.1EPSS 0.44%Fix available

    CVE-2020-25656

    A flaw was found in the Linux kernel. A use-after-free was found in the way the console subsystem was using ioctls KDGKBSENT and KDSKBSENT. A local user could use this flaw to get read memory access out of bounds. The highest threat from this vulnerability is to data confidentiality.

    • Update to 5.4.0-59.65~18.04.1
    Published Updated
  9. CVE-2020-29374

    Low · CVSS 3.6EPSS 0.4%Fix available

    CVE-2020-29374

    An issue was discovered in the Linux kernel before 5.7.3, related to mm/gup.c and mm/huge_memory.c. The get_user_pages (aka gup) implementation, when used for a copy-on-write page, does not properly consider the semantics of read operations and therefore can grant unintended write access, aka CID-17839856fd58.

    • Update to 5.4.0-45.49~18.04.2
    Published Updated
  10. CVE-2020-15437

    Medium · CVSS 4.4EPSS 0.43%Fix available

    CVE-2020-15437

    The Linux kernel before version 5.8 is vulnerable to a NULL pointer dereference in drivers/tty/serial/8250/8250_core.c:serial8250_isa_init_ports() that allows local users to cause a denial of service by using the p->serial_in pointer which uninitialized.

    • Update to 5.4.0-45.49~18.04.2
    Published Updated
  11. CVE-2020-28974

    Medium · CVSS 5EPSS 0.52%Fix available

    CVE-2020-28974

    A slab-out-of-bounds read in fbcon in the Linux kernel before 5.9.7 could be used by local attackers to read privileged information or potentially crash the kernel, aka CID-3c4e0dff2095. This occurs because KD_FONT_OP_COPY in drivers/tty/vt/vt.c can be used for manipulations such as font height.

    • Update to 5.4.0-59.65~18.04.1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →