p PatchFirst

PatchFirst · Latest vulnerabilities

linux-oracle-5.4 vulnerabilities · Page 78

Vulnerabilities published for linux-oracle-5.4 in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 1752

  1. CVE-2021-20322

    Critical · CVSS 9.1EPSS 6.9%Fix available

    CVE-2021-20322

    A flaw in the processing of received ICMP errors (ICMP fragment needed and ICMP redirect) in the Linux kernel functionality was found to allow the ability to quickly scan open UDP ports. This flaw allows an off-path remote user to effectively bypass the source port UDP randomization. The highest threat from this vulnerability is to confidentiality and possibly integrity, because software that relies on UDP source port randomization are indirectly affected as well.

    • Update to 5.4.0-1059.63~18.04.1
    Published Updated
  2. CVE-2021-3752

    High · CVSS 7.7EPSS 1.74%Fix available

    CVE-2021-3752

    A use-after-free flaw was found in the Linux kernel’s Bluetooth subsystem in the way user calls connect to the socket and disconnect simultaneously due to a race condition. This flaw allows a user to crash the system or escalate their privileges. The highest threat from this vulnerability is to confidentiality, integrity, as well as system availability.

    • Update to 5.4.0-1062.66~18.04.1
    Published Updated
  3. CVE-2022-0617

    Medium · CVSS 5.5EPSS 0.5%Fix available

    CVE-2022-0617

    A flaw null pointer dereference in the Linux kernel UDF file system functionality was found in the way user triggers udf_file_write_iter function for the malicious UDF image. A local user could use this flaw to crash the system. Actual from Linux kernel 4.2-rc1 till 5.17-rc2.

    • Update to 5.4.0-1070.76~18.04.1
    Published Updated
  4. CVE-2022-25258

    Medium · CVSS 5.1EPSS 0.92%Fix available

    CVE-2022-25258

    An issue was discovered in drivers/usb/gadget/composite.c in the Linux kernel before 5.16.10. The USB Gadget subsystem lacks certain validation of interface OS descriptor requests (ones with a large array index and ones associated with NULL function pointer retrieval). Memory corruption might occur.

    • Update to 5.4.0-1071.77~18.04.1
    Published Updated
  5. CVE-2021-3753

    High · CVSS 7.3EPSS 0.36%Fix available

    CVE-2021-3753

    A race problem was seen in the vt_k_ioctl in drivers/tty/vt/vt_ioctl.c in the Linux kernel, which may cause an out of bounds read in vt as the write access to vc_mode is not protected by lock-in vt_ioctl (KDSETMDE). The highest threat from this vulnerability is to data confidentiality.

    • Update to 5.4.0-1057.61~18.04.1
    Published Updated
  6. CVE-2022-0185

    High · CVSS 8.4EPSS 25.15%In KEVPublic exploitFix available

    CVE-2022-0185

    A heap-based buffer overflow flaw was found in the way the legacy_parse_param function in the Filesystem Context functionality of the Linux kernel verified the supplied parameters length. An unprivileged (in case of unprivileged user namespaces enabled, otherwise needs namespaced CAP_SYS_ADMIN privilege) local user able to open a filesystem that does not support the Filesystem Context API (and thus fallbacks to legacy handling) could use this flaw to escalate their privileges on the system.

    • Update to 5.4.0-1061.65~18.04.1
    Published Updated
  7. USN-5267-2

    Not ratedFix available

    linux, linux-aws, linux-aws-5.4, linux-azure, linux-azure-5.4, linux-gcp, linux-gcp-5.4, linux-gke, linux-gke-5.4, linux-gkeop, linux-gkeop-5.4, linux-hwe-5.4, linux-ibm, linux-kvm, linux-oracle, linux-oracle-5.4 regression

    USN-5267-1 fixed vulnerabilities in the Linux kernel. Unfortunately, that update introduced a regression that caused the kernel to freeze when accessing CIFS shares in some situations. This update fixes the problem. We apologize for the inconvenience. Original advisory details: It was discovered that the Bluetooth subsystem in the Linux kernel contained a use-after-free vulnerability. A local attacker could use this to cause a denial of service (system crash) or possibly execute arbitrary code. (CVE-2021-3640) Likang Luo discovered that a race condition existed in the Bluetooth subsystem of the Linux kernel, leading to a use-after-

    • Update to 5.4.0-1063.67~18.04.1
    Published Updated
  8. CVE-2022-0487

    Medium · CVSS 5.5EPSS 0.42%Fix available

    CVE-2022-0487

    A use-after-free vulnerability was found in rtsx_usb_ms_drv_remove in drivers/memstick/host/rtsx_usb_ms.c in memstick in the Linux kernel. In this flaw, a local attacker with a user privilege may impact system Confidentiality. This flaw affects kernel versions prior to 5.14 rc1.

    • Update to 5.4.0-1071.77~18.04.1
    Published Updated
  9. CVE-2021-4154

    High · CVSS 8.8EPSS 1.22%Fix available

    CVE-2021-4154

    A use-after-free flaw was found in cgroup1_parse_param in kernel/cgroup/cgroup-v1.c in the Linux kernel's cgroup v1 parser. A local attacker with a user privilege could cause a privilege escalation by exploiting the fsconfig syscall parameter leading to a container breakout and a denial of service on the system.

    • Update to 5.4.0-1055.59~18.04.1
    Published Updated
  10. CVE-2022-24448

    Medium · CVSS 4.8EPSS 0.4%Fix available

    CVE-2022-24448

    An issue was discovered in fs/nfs/dir.c in the Linux kernel before 5.16.5. If an application sets the O_DIRECTORY flag, and tries to open a regular file, nfs_atomic_open() performs a regular lookup. If a regular file is found, ENOTDIR should occur, but the server instead returns uninitialized data in the file descriptor.

    • Update to 5.4.0-1070.76~18.04.1
    Published Updated
  11. CVE-2021-22600

    Medium · CVSS 6.6EPSS 6.59%In KEVFix available

    Double Free in net/packet/af_packet.c leading to priviledge escalation

    A double free bug in packet_set_ring() in net/packet/af_packet.c can be exploited by a local user through crafted syscalls to escalate privileges or deny service. We recommend upgrading kernel past the effected versions or rebuilding past ec6af094ea28f0f2dda1a6a33b14cd57e36a9755

    • Update to 5.4.0-1064.68~18.04.1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →