p PatchFirst

PatchFirst · Latest vulnerabilities

linux-raspi-5.4 vulnerabilities · Page 87

Vulnerabilities published for linux-raspi-5.4 in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 1751

  1. CVE-2020-10781

    Medium · CVSS 5.5EPSS 0.31%Fix available

    CVE-2020-10781

    A flaw was found in the Linux Kernel before 5.8-rc6 in the ZRAM kernel module, where a user with a local account and the ability to read the /sys/class/zram-control/hot_add file can create ZRAM device nodes in the /dev/ directory. This read allocates kernel memory and is not accounted for a user that triggers the creation of that ZRAM device. With this vulnerability, continually reading the device may consume a large amount of system memory and cause the Out-of-Memory (OOM) killer to activate and terminate random userspace processes, possibly making the system inoperable.

    • Update to 5.4.0-1016.17~18.04.1
    Published Updated
  2. CVE-2020-10768

    Medium · CVSS 5.5EPSS 0.4%Fix available

    CVE-2020-10768

    A flaw was found in the Linux Kernel before 5.8-rc1 in the prctl() function, where it can be used to enable indirect branch speculation after it has been disabled. This call incorrectly reports it as being 'force disabled' when it is not and opens the system to Spectre v2 attacks. The highest threat from this vulnerability is to confidentiality.

    • Update to 5.4.0-1016.17~18.04.1
    Published Updated
  3. CVE-2020-10767

    Medium · CVSS 5.5EPSS 0.38%Fix available

    CVE-2020-10767

    A flaw was found in the Linux kernel before 5.8-rc1 in the implementation of the Enhanced IBPB (Indirect Branch Prediction Barrier). The IBPB mitigation will be disabled when STIBP is not available or when the Enhanced Indirect Branch Restricted Speculation (IBRS) is available. This flaw allows a local attacker to perform a Spectre V2 style attack when this configuration is active. The highest threat from this vulnerability is to confidentiality.

    • Update to 5.4.0-1016.17~18.04.1
    Published Updated
  4. CVE-2020-10766

    Medium · CVSS 5.5EPSS 0.46%Fix available

    CVE-2020-10766

    A logic bug flaw was found in Linux kernel before 5.8-rc1 in the implementation of SSBD. A bug in the logic handling allows an attacker with a local account to disable SSBD protection during a context switch when additional speculative execution mitigations are in place. This issue was introduced when the per task/process conditional STIPB switching was added on top of the existing SSBD switching. The highest threat from this vulnerability is to confidentiality.

    • Update to 5.4.0-1016.17~18.04.1
    Published Updated
  5. CVE-2020-14385

    Medium · CVSS 5.5EPSS 0.42%Fix available

    CVE-2020-14385

    A flaw was found in the Linux kernel before 5.9-rc4. A failure of the file system metadata validator in XFS can cause an inode with a valid, user-creatable extended attribute to be flagged as corrupt. This can lead to the filesystem being shutdown, or otherwise rendered inaccessible until it is remounted, leading to a denial of service. The highest threat from this vulnerability is to system availability.

    • Update to 5.4.0-1021.24~18.04.1
    Published Updated
  6. CVE-2020-14314

    Medium · CVSS 5.5EPSS 0.37%Fix available

    CVE-2020-14314

    A memory out-of-bounds read flaw was found in the Linux kernel before 5.9-rc2 with the ext3/ext4 file system, in the way it accesses a directory with broken indexing. This flaw allows a local user to crash the system if the directory exists. The highest threat from this vulnerability is to system availability.

    • Update to 5.4.0-1021.24~18.04.1
    Published Updated
  7. CVE-2020-25212

    High · CVSS 7EPSS 0.27%Fix available

    CVE-2020-25212

    A TOCTOU mismatch in the NFS client code in the Linux kernel before 5.8.3 could be used by local attackers to corrupt memory or possibly have unspecified other impact because a size check is in fs/nfs/nfs4proc.c instead of fs/nfs/nfs4xdr.c, aka CID-b4487b935452.

    • Update to 5.4.0-1019.21~18.04.1
    Published Updated
  8. CVE-2020-25211

    Medium · CVSS 6EPSS 0.57%Fix available

    CVE-2020-25211

    In the Linux kernel through 5.8.7, local attackers able to inject conntrack netlink configuration could overflow a local buffer, causing crashes or triggering use of incorrect protocol numbers in ctnetlink_parse_tuple_filter in net/netfilter/nf_conntrack_netlink.c, aka CID-1cc5ef91d2ff.

    • Update to 5.4.0-1023.26~18.04.1
    Published Updated
  9. CVE-2020-3702

    Medium · CVSS 6.5EPSS 0.33%Fix available

    CVE-2020-3702

    u'Specifically timed and handcrafted traffic can cause internal errors in a WLAN device that lead to improper layer 2 Wi-Fi encryption with a consequent possibility of information disclosure over the air for a discrete set of traffic' in Snapdragon Auto, Snapdragon Compute, Snapdragon Connectivity, Snapdragon Consumer IOT, Snapdragon Industrial IOT, Snapdragon Mobile, Snapdragon Voice & Music, Snapdragon Wearables, Snapdragon Wired Infrastructure and Networking in APQ8053, IPQ4019, IPQ8064, MSM8909W, MSM8996AU, QCA9531, QCN5502, QCS405, SDX20, SM6150, SM7150

    • Update to 5.4.0-1045.49~18.04.1
    Published Updated
  10. CVE-2020-13974

    High · CVSS 7.8EPSS 0.57%Fix available

    CVE-2020-13974

    An issue was discovered in the Linux kernel 4.4 through 5.7.1. drivers/tty/vt/keyboard.c has an integer overflow if k_ascii is called several times in a row, aka CID-b86dab054059. NOTE: Members in the community argue that the integer overflow does not lead to a security issue in this case.

    • Update to 5.4.0-1016.17~18.04.1
    Published Updated
  11. CVE-2020-10135

    Medium · CVSS 5.4EPSS 2.37%Fix available

    Bluetooth devices supporting BR/EDR v5.2 and earlier are vulnerable to impersonation attacks

    Legacy pairing and secure-connections pairing authentication in Bluetooth BR/EDR Core Specification v5.2 and earlier may allow an unauthenticated user to complete authentication without pairing credentials via adjacent access. An unauthenticated, adjacent attacker could impersonate a Bluetooth BR/EDR master or slave to pair with a previously paired remote device to successfully complete the authentication procedure without knowing the link key.

    • Update to 5.4.0-1023.26~18.04.1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →