p PatchFirst

PatchFirst · Latest vulnerabilities

linux-raspi2 vulnerabilities · Page 4

Vulnerabilities published for linux-raspi2 in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 740

  1. CVE-2022-3566

    Low · CVSS 2.1EPSS 0.74%Fix available

    Linux Kernel TCP tcp_setsockopt race condition

    A vulnerability was identified in Linux Kernel up to 4.19.316/5.4.278/5.10.220/5.15.161. This impacts the function tcp_getsockopt/tcp_setsockopt of the component TCP Handler. Such manipulation leads to race condition. A high complexity level is associated with this attack. The exploitability is said to be difficult. The vulnerability was introduced in 2.6.12, commit 1da177e4c3f41524e886b7f1b8a0c1fc7321cac2 ("Linux-2.6.12-rc2"). Upgrading to version 4.19.317, 5.4.279, 5.10.221, 5.15.162 and 6.1 will fix this issue. The name of the patch is fcd31dd8291b23d713245947ec2b2d99ef07aef2/3b32f265805a49071e2c4568a524398ba22bf93c/d529193eae979a7bf2255cd

    • Update to 4.15.0-1124.132
    Published Updated
  2. CVE-2022-3565

    Medium · CVSS 4.6EPSS 0.35%Fix available

    Linux Kernel Bluetooth l1oip_core.c del_timer use after free

    A vulnerability, which was classified as critical, has been found in Linux Kernel. Affected by this issue is the function del_timer of the file drivers/isdn/mISDN/l1oip_core.c of the component Bluetooth. The manipulation leads to use after free. It is recommended to apply a patch to fix this issue. The identifier of this vulnerability is VDB-211088.

    • Update to 4.15.0-1124.132
    Published Updated
  3. CVE-2022-3564

    Medium · CVSS 5.5EPSS 1.46%Fix available

    Linux Kernel Bluetooth l2cap_core.c l2cap_reassemble_sdu use after free

    A vulnerability classified as critical was found in Linux Kernel. Affected by this vulnerability is the function l2cap_reassemble_sdu of the file net/bluetooth/l2cap_core.c of the component Bluetooth. The manipulation leads to use after free. It is recommended to apply a patch to fix this issue. The associated identifier of this vulnerability is VDB-211087.

    • Update to 4.15.0-1124.132
    Published Updated
  4. CVE-2022-3545

    Medium · CVSS 5.5EPSS 0.44%Fix available

    Linux Kernel IPsec nfp_cppcore.c area_cache_get use after free

    A vulnerability has been found in Linux Kernel and classified as critical. Affected by this vulnerability is the function area_cache_get of the file drivers/net/ethernet/netronome/nfp/nfpcore/nfp_cppcore.c of the component IPsec. The manipulation leads to use after free. It is recommended to apply a patch to fix this issue. The identifier VDB-211045 was assigned to this vulnerability.

    • Update to 4.15.0-1128.136
    Published Updated
  5. CVE-2022-3524

    Medium · CVSS 4.3EPSS 1.08%Fix available

    Linux Kernel IPv6 ipv6_renew_options memory leak

    A vulnerability was found in Linux Kernel. It has been declared as problematic. Affected by this vulnerability is the function ipv6_renew_options of the component IPv6 Handler. The manipulation leads to memory leak. The attack can be launched remotely. It is recommended to apply a patch to fix this issue. The identifier VDB-211021 was assigned to this vulnerability.

    • Update to 4.15.0-1124.132
    Published Updated
  6. CVE-2022-3521

    Low · CVSS 2.6EPSS 0.24%Fix available

    Linux Kernel kcm kcmsock.c kcm_tx_work race condition

    A vulnerability has been found in Linux Kernel and classified as problematic. This vulnerability affects the function kcm_tx_work of the file net/kcm/kcmsock.c of the component kcm. The manipulation leads to race condition. It is recommended to apply a patch to fix this issue. VDB-211018 is the identifier assigned to this vulnerability.

    • Update to 4.15.0-1128.136
    Published Updated
  7. CVE-2022-20423

    Medium · CVSS 4.6EPSS 0.27%Fix available

    CVE-2022-20423

    In rndis_set_response of rndis.c, there is a possible out of bounds write due to an integer overflow. This could lead to local escalation of privilege if a malicious USB device is attached with no additional execution privileges needed. User interaction is not needed for exploitation.Product: AndroidVersions: Android kernelAndroid ID: A-239842288References: Upstream kernel

    • Update to 4.15.0-1114.122
    Published Updated
  8. CVE-2022-20422

    High · CVSS 7EPSS 0.19%Fix available

    CVE-2022-20422

    In emulation_proc_handler of armv8_deprecated.c, there is a possible way to corrupt memory due to a race condition. This could lead to local escalation of privilege with no additional execution privileges needed. User interaction is not needed for exploitation.Product: AndroidVersions: Android kernelAndroid ID: A-237540956References: Upstream kernel

    • Update to 4.15.0-1121.129
    Published Updated
  9. CVE-2022-20421

    High · CVSS 7.8EPSS 0.62%Fix available

    CVE-2022-20421

    In binder_inc_ref_for_node of binder.c, there is a possible way to corrupt memory due to a use after free. This could lead to local escalation of privilege with no additional execution privileges needed. User interaction is not needed for exploitation.Product: AndroidVersions: Android kernelAndroid ID: A-239630375References: Upstream kernel

    • Update to 4.15.0-1125.133
    Published Updated
  10. CVE-2022-2977

    High · CVSS 7.8EPSS 0.24%Fix available

    CVE-2022-2977

    A flaw was found in the Linux kernel implementation of proxied virtualized TPM devices. On a system where virtualized TPM devices are configured (this is not the default) a local attacker can create a use-after-free and create a situation where it may be possible to escalate privileges on the system.

    • Update to 4.15.0-1115.123
    Published Updated
  11. CVE-2022-36280

    Medium · CVSS 6.3EPSS 0.78%Fix available

    There is an out-of-bounds write vulnerability in vmwgfx driver

    An out-of-bounds(OOB) memory access vulnerability was found in vmwgfx driver in drivers/gpu/vmxgfx/vmxgfx_kms.c in GPU component in the Linux kernel with device file '/dev/dri/renderD128 (or Dxxx)'. This flaw allows a local attacker with a user account on the system to gain privilege, causing a denial of service(DoS).

    • Update to 4.15.0-1129.137
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →