p PatchFirst

PatchFirst · Latest vulnerabilities

postgresql-10 vulnerabilities · Page 2

Vulnerabilities published for postgresql-10 in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 23

  1. CVE-2018-10915

    High · CVSS 8.5EPSS 5.09%Fix available

    CVE-2018-10915

    A vulnerability was found in libpq, the default PostgreSQL client library where libpq failed to properly reset its internal state between connections. If an affected version of libpq was used with "host" or "hostaddr" connection parameters from untrusted input, attackers could bypass client-side connection security features, obtain access to higher privileged connections or potentially cause other impact through SQL injection, by causing the PQescape() functions to malfunction. Postgresql versions before 10.5, 9.6.10, 9.5.14, 9.4.19, and 9.3.24 are affected.

    • Update to 10.5-0ubuntu0.18.04
    Published Updated
  2. CVE-2018-1115

    Medium · CVSS 4.2EPSS 3.83%Fix available

    CVE-2018-1115

    postgresql before versions 10.4, 9.6.9 is vulnerable in the adminpack extension, the pg_catalog.pg_logfile_rotate() function doesn't follow the same ACLs than pg_rorate_logfile. If the adminpack is added to a database, an attacker able to connect to it could exploit this to force log rotation.

    • Update to 10.4-0ubuntu0.18.04
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →