p PatchFirst

PatchFirst · Latest vulnerabilities

qemu vulnerabilities · Page 3

Vulnerabilities published for qemu in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 86

  1. CVE-2020-10756

    Medium · CVSS 6.5EPSS 0.51%Fix available

    CVE-2020-10756

    An out-of-bounds read vulnerability was found in the SLiRP networking implementation of the QEMU emulator. This flaw occurs in the icmp6_send_echoreply() routine while replying to an ICMP echo request, also known as ping. This flaw allows a malicious guest to leak the contents of the host memory, resulting in possible information disclosure. This flaw affects versions of libslirp before 4.3.1.

    • Update to 1:2.11+dfsg-1ubuntu7.31
    Published Updated
  2. CVE-2020-1711

    High · CVSS 7.7EPSS 4.02%Fix available

    CVE-2020-1711

    An out-of-bounds heap buffer access flaw was found in the way the iSCSI Block driver in QEMU versions 2.12.0 before 4.2.1 handled a response coming from an iSCSI server while checking the status of a Logical Address Block (LBA) in an iscsi_co_block_status() routine. A remote user could use this flaw to crash the QEMU process, resulting in a denial of service or potential execution of arbitrary code with privileges of the QEMU process on the host.

    • Update to 1:2.11+dfsg-1ubuntu7.23
    Published Updated
  3. CVE-2020-7039

    Medium · CVSS 5.6EPSS 3.57%Fix available

    CVE-2020-7039

    tcp_emu in tcp_subr.c in libslirp 4.1.0, as used in QEMU 4.2.0, mismanages memory, as demonstrated by IRC DCC commands in EMU_IRC. This can cause a heap-based buffer overflow or other out-of-bounds access which can lead to a DoS or potential execute arbitrary code.

    • Update to 1:2.11+dfsg-1ubuntu7.23
    Published Updated
  4. CVE-2019-12068

    Low · CVSS 3.8EPSS 0.51%Fix available

    CVE-2019-12068

    In QEMU 1:4.1-1, 1:2.1+dfsg-12+deb8u6, 1:2.8+dfsg-6+deb9u8, 1:3.1+dfsg-8~deb10u1, 1:3.1+dfsg-8+deb10u2, and 1:2.1+dfsg-12+deb8u12 (fixed), when executing script in lsi_execute_script(), the LSI scsi adapter emulator advances 's->dsp' index to read next opcode. This can lead to an infinite loop if the next opcode is empty. Move the existing loop exit after 10k iterations so that it covers no-op opcodes as well.

    • Update to 1:2.11+dfsg-1ubuntu7.20
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →