p PatchFirst

PatchFirst · Latest vulnerabilities

xorg-server vulnerabilities · Page 2

Vulnerabilities published for xorg-server in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 24

  1. CVE-2020-14361

    High · CVSS 7.8EPSS 0.61%Fix available

    CVE-2020-14361

    A flaw was found in X.Org Server before xorg-x11-server 1.20.9. An Integer underflow leading to heap-buffer overflow may lead to a privilege escalation vulnerability. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability.

    • Update to 2:1.19.6-1ubuntu4.5
    Published Updated
  2. CVE-2020-14346

    High · CVSS 7.8EPSS 0.63%Fix available

    CVE-2020-14346

    A flaw was found in xorg-x11-server before 1.20.9. An integer underflow in the X input extension protocol decoding in the X server may lead to arbitrary access of memory contents. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability.

    • Update to 2:1.19.6-1ubuntu4.5
    Published Updated
  3. CVE-2020-14347

    Medium · CVSS 5.5EPSS 0.39%Fix available

    CVE-2020-14347

    A flaw was found in the way xserver memory was not properly initialized. This could leak parts of server memory to the X client. In cases where Xorg server runs with elevated privileges, this could result in possible ASLR bypass. Xorg-server before version 1.20.9 is vulnerable.

    • Update to 2:1.19.6-1ubuntu4.5
    Published Updated
  4. CVE-2018-14665

    Medium · CVSS 6.6EPSS 27.24%Public exploitFix available

    CVE-2018-14665

    A flaw was found in xorg-x11-server before 1.20.3. An incorrect permission check for -modulepath and -logfile options when starting Xorg. X server allows unprivileged users with the ability to log in to the system via physical console to escalate their privileges and run arbitrary code under root privileges.

    • Update to 2:1.19.6-1ubuntu4.2
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →