p PatchFirst

PatchFirst · Latest vulnerabilities

apache2 vulnerabilities · Page 2

Vulnerabilities published for apache2 in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 49

  1. CVE-2022-28615

    Critical · CVSS 9.1EPSS 6.28%Fix available

    Read beyond bounds in ap_strcmp_match()

    Apache HTTP Server 2.4.53 and earlier may crash or disclose information due to a read beyond bounds in ap_strcmp_match() when provided with an extremely large input buffer. While no code distributed with the server can be coerced into such a call, third-party modules or lua scripts that use ap_strcmp_match() may hypothetically be affected.

    • Update to 2.4.41-4ubuntu3.12
    Published Updated
  2. CVE-2022-28614

    Medium · CVSS 5.3EPSS 4.98%Fix available

    read beyond bounds via ap_rwrite()

    The ap_rwrite() function in Apache HTTP Server 2.4.53 and earlier may read unintended memory if an attacker can cause the server to reflect very large input using ap_rwrite() or ap_rputs(), such as with mod_luas r:puts() function. Modules compiled and distributed separately from Apache HTTP Server that use the 'ap_rputs' function and may pass it a very large (INT_MAX or larger) string must be compiled against current headers to resolve the issue.

    • Update to 2.4.41-4ubuntu3.12
    Published Updated
  3. CVE-2022-26377

    High · CVSS 7.5EPSS 21.08%Fix available

    mod_proxy_ajp: Possible request smuggling

    Inconsistent Interpretation of HTTP Requests ('HTTP Request Smuggling') vulnerability in mod_proxy_ajp of Apache HTTP Server allows an attacker to smuggle requests to the AJP server it forwards requests to. This issue affects Apache HTTP Server Apache HTTP Server 2.4 version 2.4.53 and prior versions.

    • Update to 2.4.41-4ubuntu3.12
    Published Updated
  4. CVE-2022-22721

    Critical · CVSS 9.1EPSS 41.71%Fix available

    core: Possible buffer overflow with very large or unlimited LimitXMLRequestBody

    If LimitXMLRequestBody is set to allow request bodies larger than 350MB (defaults to 1M) on 32 bit systems an integer overflow happens which later causes out of bounds writes. This issue affects Apache HTTP Server 2.4.52 and earlier.

    • Update to 2.4.41-4ubuntu3.10
    Published Updated
  5. CVE-2021-44224

    High · CVSS 8.2EPSS 82.3%Fix available

    Possible NULL dereference or SSRF in forward proxy configurations in Apache HTTP Server 2.4.51 and earlier

    A crafted URI sent to httpd configured as a forward proxy (ProxyRequests on) can cause a crash (NULL pointer dereference) or, for configurations mixing forward and reverse proxy declarations, can allow for requests to be directed to a declared Unix Domain Socket endpoint (Server Side Request Forgery). This issue affects Apache HTTP Server 2.4.7 up to 2.4.51 (included).

    • Update to 2.4.41-4ubuntu3.9
    Published Updated
  6. CVE-2021-44790

    Critical · CVSS 9.8EPSS 96.84%Public exploitFix available

    Possible buffer overflow when parsing multipart content in mod_lua of Apache HTTP Server 2.4.51 and earlier

    A carefully crafted request body can cause a buffer overflow in the mod_lua multipart parser (r:parsebody() called from Lua scripts). The Apache httpd team is not aware of an exploit for the vulnerabilty though it might be possible to craft one. This issue affects Apache HTTP Server 2.4.51 and earlier.

    • Update to 2.4.41-4ubuntu3.9
    Published Updated
  7. USN-5090-3

    Not ratedFix available

    apache2 regression

    USN-5090-1 fixed vulnerabilities in Apache HTTP Server. One of the upstream fixes introduced a regression in UDS URIs. This update fixes the problem. Original advisory details: James Kettle discovered that the Apache HTTP Server HTTP/2 module incorrectly handled certain crafted methods. A remote attacker could possibly use this issue to perform request splitting or cache poisoning attacks. (CVE-2021-33193) It was discovered that the Apache HTTP Server incorrectly handled certain malformed requests. A remote attacker could possibly use this issue to cause the server to crash, resulting in a denial of service. (CVE-2021-34798) Li

    • Update to 2.4.41-4ubuntu3.6
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →