p PatchFirst

PatchFirst · Latest vulnerabilities

php7.4 vulnerabilities · Page 3

Vulnerabilities published for php7.4 in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 46

  1. CVE-2020-7065

    High · CVSS 7.4EPSS 4.88%Fix available

    mb_strtolower (UTF-32LE): stack-buffer-overflow at php_unicode_tolower_full

    In PHP versions 7.3.x below 7.3.16 and 7.4.x below 7.4.4, while using mb_strtolower() function with UTF-32LE encoding, certain invalid strings could cause PHP to overwrite stack-allocated buffer. This could lead to memory corruption, crashes and potentially code execution.

    • Update to 7.4.3-4ubuntu1.1
    Published Updated
  2. CVE-2020-7064

    Medium · CVSS 6.5EPSS 4.29%Fix available

    Use-of-uninitialized-value in exif

    In PHP versions 7.2.x below 7.2.9, 7.3.x below 7.3.16 and 7.4.x below 7.4.4, while parsing EXIF data with exif_read_data() function, it is possible for malicious data to cause PHP to read one byte of uninitialized memory. This could potentially lead to information disclosure or crash.

    • Update to 7.4.3-4ubuntu1.1
    Published Updated
  3. CVE-2017-8923

    Critical · CVSS 9.8EPSS 7.19%Fix available

    CVE-2017-8923

    The zend_string_extend function in Zend/zend_string.h in PHP through 7.1.5 does not prevent changes to string objects that result in a negative length, which allows remote attackers to cause a denial of service (application crash) or possibly have unspecified other impact by leveraging a script's use of .= with a long string.

    • Update to 7.4.3-4ubuntu2.10
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →