p PatchFirst

PatchFirst · Latest vulnerabilities

php8.1 vulnerabilities · Page 4

Vulnerabilities published for php8.1 in the last 30 days: 2. Listed in the KEV catalogue: 2.

Filter vulnerabilities
Clear filters

Vulnerabilities: 63

  1. CVE-2021-21708

    High · CVSS 8.2EPSS 3%Fix available

    UAF due to php_filter_float() failing

    In PHP versions 7.4.x below 7.4.28, 8.0.x below 8.0.16, and 8.1.x below 8.1.3, when using filter functions with FILTER_VALIDATE_FLOAT filter and min/max limits, if the filter fails, there is a possibility to trigger use of allocated memory after free, which can result it crashes, and potentially in overwrite of other memory chunks and RCE. This issue affects: code that uses FILTER_VALIDATE_FLOAT with min/max limits.

    • Update to 8.1.2-1ubuntu1
    Published Updated
  2. CVE-2017-7189

    High · CVSS 7.5EPSS 2.43%No fix published

    CVE-2017-7189

    main/streams/xp_socket.c in PHP 7.x before 2017-03-07 misparses fsockopen calls, such as by interpreting fsockopen('127.0.0.1:80', 443) as if the address/port were 127.0.0.1:80:443, which is later truncated to 127.0.0.1:80. This behavior has a security risk if the explicitly provided port number (i.e., 443 in this example) is hardcoded into an application as a security policy, but the hostname argument (i.e., 127.0.0.1:80 in this example) is obtained from untrusted input.

    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →