p PatchFirst

PatchFirst · Latest vulnerabilities

glib2.0 vulnerabilities · Page 2

Vulnerabilities published for glib2.0 in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 23

  1. CVE-2025-3360

    Low · CVSS 3.7EPSS 0.65%Fix available

    Glibc: glib prior to 2.82.5 is vulnerable to integer overflow and buffer under-read when parsing a very long invalid iso 8601 timestamp with g_date_time_new_from_iso8601().

    A flaw was found in GLib. An integer overflow and buffer under-read occur when parsing a long invalid ISO 8601 timestamp with the g_date_time_new_from_iso8601() function.

    • Update to 2.80.0-6ubuntu3.6
    Published Updated
  2. CVE-2024-34397

    Medium · CVSS 5.2EPSS 0.76%Fix available

    CVE-2024-34397

    An issue was discovered in GNOME GLib before 2.78.5, and 2.79.x and 2.80.x before 2.80.1. When a GDBus-based client subscribes to signals from a trusted system service such as NetworkManager on a shared computer, other users of the same computer can send spoofed D-Bus signals that the GDBus-based client will wrongly interpret as having been sent by the trusted system service. This could lead to the GDBus-based client behaving incorrectly, with an application-dependent impact.

    • Update to 2.80.0-6ubuntu3.1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →