p PatchFirst

PatchFirst · Latest vulnerabilities

php8.3 vulnerabilities · Page 3

Vulnerabilities published for php8.3 in the last 30 days: 2. Listed in the KEV catalogue: 2.

Filter vulnerabilities
Clear filters

Vulnerabilities: 48

  1. CVE-2024-9026

    Low · CVSS 3.3EPSS 0.49%Fix available

    PHP-FPM logs from children may be altered

    In PHP versions 8.1.* before 8.1.30, 8.2.* before 8.2.24, 8.3.* before 8.3.12, when using PHP-FPM SAPI and it is configured to catch workers output through catch_workers_output = yes, it may be possible to pollute the final log or remove up to 4 characters from the log messages by manipulating log message content. Additionally, if PHP-FPM is configured to use syslog output, it may be possible to further remove log data using the same vulnerability.

    • Update to 8.3.6-0ubuntu0.24.04.2
    Published Updated
  2. CVE-2024-8927

    High · CVSS 7.5EPSS 1.05%Fix available

    cgi.force_redirect configuration is bypassable due to the environment variable collision

    In PHP versions 8.1.* before 8.1.30, 8.2.* before 8.2.24, 8.3.* before 8.3.12, HTTP_REDIRECT_STATUS variable is used to check whether or not CGI binary is being run by the HTTP server. However, in certain scenarios, the content of this variable can be controlled by the request submitter via HTTP headers, which can lead to cgi.force_redirect option not being correctly applied. In certain configurations this may lead to arbitrary file inclusion in PHP.

    • Update to 8.3.6-0ubuntu0.24.04.2
    Published Updated
  3. CVE-2024-8925

    Low · CVSS 3.1EPSS 0.94%Fix available

    Erroneous parsing of multipart form data

    In PHP versions 8.1.* before 8.1.30, 8.2.* before 8.2.24, 8.3.* before 8.3.12, erroneous parsing of multipart form data contained in an HTTP POST request could lead to legitimate data not being processed. This could lead to malicious attacker able to control part of the submitted data being able to exclude portion of other data, potentially leading to erroneous application behavior.

    • Update to 8.3.6-0ubuntu0.24.04.2
    Published Updated
  4. CVE-2024-5458

    Medium · CVSS 5.3EPSS 12.12%Fix available

    Filter bypass in filter_var (FILTER_VALIDATE_URL)

    In PHP versions 8.1.* before 8.1.29, 8.2.* before 8.2.20, 8.3.* before 8.3.8, due to a code logic error, filtering functions such as filter_var when validating URLs (FILTER_VALIDATE_URL) for certain types of URLs the function will result in invalid user information (username + password part of URLs) being treated as valid user information. This may lead to the downstream code accepting invalid URLs as valid and parsing them incorrectly.

    • Update to 8.3.6-0ubuntu0.24.04.1
    Published Updated
  5. CVE-2024-2757

    High · CVSS 7.5EPSS 1.92%Fix available

    PHP mb_encode_mimeheader runs endlessly for some inputs

    In PHP 8.3.* before 8.3.5, function mb_encode_mimeheader() runs endlessly for some inputs that contain long strings of non-space characters followed by a space. This could lead to a potential DoS attack if a hostile user sends data to an application that uses this function.

    • Update to 8.3.6-0maysync1
    Published Updated
  6. CVE-2024-3096

    Medium · CVSS 6.5EPSS 1.49%Fix available

    PHP function password_verify can erroneously return true when argument contains NUL

    In PHP  version 8.1.* before 8.1.28, 8.2.* before 8.2.18, 8.3.* before 8.3.5, if a password stored with password_hash() starts with a null byte (\x00), testing a blank string as the password via password_verify() will incorrectly return true.

    • Update to 8.3.6-0maysync1
    Published Updated
  7. CVE-2024-2756

    Medium · CVSS 6.5EPSS 38.12%Fix available

    __Host-/__Secure- cookie bypass due to partial CVE-2022-31629 fix

    Due to an incomplete fix to CVE-2022-31629 https://github.com/advisories/GHSA-c43m-486j-j32p , network and same-site attackers can set a standard insecure cookie in the victim's browser which is treated as a __Host- or __Secure- cookie by PHP applications.

    • Update to 8.3.6-0maysync1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →