p PatchFirst

PatchFirst · Latest vulnerabilities

python3.12 vulnerabilities · Page 4

Vulnerabilities published for python3.12 in the last 30 days: 5. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 71

  1. CVE-2025-4516

    Medium · CVSS 5.9EPSS 0.22%Fix available

    Use-after-free in "unicode_escape" decoder with error handler

    There is an issue in CPython when using `bytes.decode("unicode_escape", error="ignore|replace")`. If you are not using the "unicode_escape" encoding or an error handler your usage is not affected. To work-around this issue you may stop using the error= handler and instead wrap the bytes.decode() call in a try-except catching the DecodeError.

    • Update to 3.12.3-1ubuntu0.6
    Published Updated
  2. CVE-2025-1795

    Low · CVSS 2.3EPSS 0.63%Fix available

    Mishandling of comma during folding and unicode-encoding of email headers

    During an address list folding when a separating comma ends up on a folded line and that line is to be unicode-encoded then the separator itself is also unicode-encoded. Expected behavior is that the separating comma remains a plan comma. This can result in the address header being misinterpreted by some mail servers.

    • Update to 3.12.3-1ubuntu0.6
    Published Updated
  3. CVE-2025-0938

    Medium · CVSS 6.3EPSS 1.56%Fix available

    URL parser allowed square brackets in domain names

    The Python standard library functions `urllib.parse.urlsplit` and `urlparse` accepted domain names that included square brackets which isn't valid according to RFC 3986. Square brackets are only meant to be used as delimiters for specifying IPv6 and IPvFuture hosts in URLs. This could result in differential parsing across the Python URL parser and other specification-compliant URL parsers.

    • Update to 3.12.3-1ubuntu0.5
    Published Updated
  4. CVE-2024-12254

    High · CVSS 8.7EPSS 1.87%Fix available

    Unbounded memory buffering in SelectorSocketTransport.writelines()

    Starting in Python 3.12.0, the asyncio._SelectorSocketTransport.writelines() method would not "pause" writing and signal to the Protocol to drain the buffer to the wire once the write buffer reached the "high-water mark". Because of this, Protocols would not periodically drain the write buffer potentially leading to memory exhaustion. This vulnerability likely impacts a small number of users, you must be using Python 3.12.0 or later, on macOS or Linux, using the asyncio module with protocols, and using .writelines() method which had new zero-copy-on-write behavior in Python 3.12.0 and later. If not all of these factors are true

    • Update to 3.12.3-1ubuntu0.4
    Published Updated
  5. CVE-2024-9287

    Medium · CVSS 5.3EPSS 0.65%Fix available

    Virtual environment (venv) activation scripts don't quote paths

    A vulnerability has been found in the CPython `venv` module and CLI where path names provided when creating a virtual environment were not quoted properly, allowing the creator to inject commands into virtual environment "activation" scripts (ie "source venv/bin/activate"). This means that attacker-controlled virtual environments are able to run commands when the virtual environment is activated. Virtual environments which are not created by an attacker or which aren't activated before being used (ie "./venv/bin/python") are not affected.

    • Update to 3.12.3-1ubuntu0.3
    Published Updated
  6. CVE-2024-8088

    High · CVSS 8.7EPSS 1.27%Fix available

    Infinite loop when iterating over zip archive entry names from zipfile.Path

    There is a HIGH severity vulnerability affecting the CPython "zipfile" module affecting "zipfile.Path". Note that the more common API "zipfile.ZipFile" class is unaffected. When iterating over names of entries in a zip archive (for example, methods of "zipfile.Path" like "namelist()", "iterdir()", etc) the process can be put into an infinite loop with a maliciously crafted zip archive. This defect applies when reading only metadata or extracting the contents of the zip archive. Programs that are not handling user-controlled zip archives are not affected.

    • Update to 3.12.3-1ubuntu0.2
    Published Updated
  7. CVE-2024-7592

    High · CVSS 7.5EPSS 2.3%Fix available

    Quadratic complexity parsing cookies with backslashes

    There is a LOW severity vulnerability affecting CPython, specifically the 'http.cookies' standard library module. When parsing cookies that contained backslashes for quoted characters in the cookie value, the parser would use an algorithm with quadratic complexity, resulting in excess CPU resources being used while parsing the value.

    • Update to 3.12.3-1ubuntu0.2
    Published Updated
  8. CVE-2024-4032

    High · CVSS 7.5EPSS 1.08%Fix available

    Incorrect IPv4 and IPv6 private ranges

    The “ipaddress” module contained incorrect information about whether certain IPv4 and IPv6 addresses were designated as “globally reachable” or “private”. This affected the is_private and is_global properties of the ipaddress.IPv4Address, ipaddress.IPv4Network, ipaddress.IPv6Address, and ipaddress.IPv6Network classes, where values wouldn’t be returned in accordance with the latest information from the IANA Special-Purpose Address Registries. CPython 3.12.4 and 3.13.0a6 contain updated information from these registries and thus have the intended behavior.

    • Update to 3.12.3-1ubuntu0.1
    Published Updated
  9. CVE-2023-27043

    Medium · CVSS 5.3EPSS 2.53%Fix available

    CVE-2023-27043

    The email module of Python through 3.11.3 incorrectly parses e-mail addresses that contain a special character. The wrong portion of an RFC2822 header is identified as the value of the addr-spec. In some applications, an attacker can bypass a protection mechanism in which application access is granted only after verifying receipt of e-mail to a specific domain (e.g., only @company.example.com addresses may be used for signup). This occurs in email/_parseaddr.py in recent versions of Python.

    • Update to 3.12.3-1ubuntu0.2
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →