p PatchFirst

PatchFirst · Latest vulnerabilities

mediawiki vulnerabilities · Page 6

Vulnerabilities published for mediawiki in the last 30 days: 11. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 163

  1. CVE-2025-32697

    Low · CVSS 0EPSS 0.39%No fix published

    Cascading protection is not preventing file reversions

    Improper Preservation of Permissions vulnerability in Wikimedia Foundation MediaWiki. This vulnerability is associated with program files includes/editpage/IntroMessageBuilder.Php, includes/Permissions/PermissionManager.Php, includes/Permissions/RestrictionStore.Php. This issue affects MediaWiki: before 1.42.6, 1.43.1.

    Published Updated
  2. CVE-2025-32696

    Low · CVSS 0EPSS 0.36%No fix published

    "reupload-own" restriction can be bypassed by reverting file

    Improper Preservation of Permissions vulnerability in Wikimedia Foundation MediaWiki. This vulnerability is associated with program files includes/actions/RevertAction.Php, includes/api/ApiFileRevert.Php. This issue affects MediaWiki: before 1.39.12, 1.42.6, 1.43.1.

    Published Updated
  3. CVE-2025-3469

    Low · CVSS 0EPSS 0.44%No fix published

    i18n XSS vulnerability in HTMLMultiSelectField when sections are used

    Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in Wikimedia Foundation MediaWiki. This vulnerability is associated with program files includes/htmlform/fields/HTMLMultiSelectField.Php. This issue affects MediaWiki: before 1.39.12, 1.42.6, 1.43.1.

    Published Updated
  4. CVE-2024-36123

    Medium · CVSS 6.5EPSS 0.47%No fix published

    Citizen has a Stored Cross-Site Scripting Vulnerability by editing MediaWiki:Tagline

    Citizen is a MediaWiki skin that makes extensions part of the cohesive experience. The page `MediaWiki:Tagline` has its contents used unescaped, so custom HTML (including Javascript) can be injected by someone with the ability to edit the MediaWiki namespace (typically those with the `editinterface` permission, or sysops). This vulnerability is fixed in 2.16.0.

    Published Updated
  5. CVE-2023-45364

    Medium · CVSS 5.3EPSS 0.5%No fix published

    CVE-2023-45364

    An issue was discovered in includes/page/Article.php in MediaWiki 1.36.x through 1.39.x before 1.39.5 and 1.40.x before 1.40.1. Deleted revision existence is leaked due to incorrect permissions being checked. This reveals that a given revision ID belonged to the given page title, and its timestamp, both of which are not supposed to be public information.

    Published Updated
  6. CVE-2023-45363

    High · CVSS 7.5EPSS 23.78%No fix published

    CVE-2023-45363

    An issue was discovered in ApiPageSet.php in MediaWiki before 1.35.12, 1.36.x through 1.39.x before 1.39.5, and 1.40.x before 1.40.1. It allows attackers to cause a denial of service (unbounded loop and RequestTimeoutException) when querying pages redirected to other variants with redirects and converttitles set.

    Published Updated
  7. CVE-2023-3550

    High · CVSS 7.3EPSS 1.38%No fix published

    Stored XSS leads to privilege escalation in MediaWiki v1.40.0

    Mediawiki v1.40.0 does not validate namespaces used in XML files. Therefore, if the instance administrator allows XML file uploads, a remote attacker with a low-privileged user account can use this exploit to become an administrator by sending a malicious link to the instance administrator.

    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →