p PatchFirst

PatchFirst · Latest vulnerabilities

linux vulnerabilities · Page 189

Vulnerabilities published for linux in the last 30 days: 206. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 4199

  1. CVE-2021-22555

    High · CVSS 8.3EPSS 78.68%In KEVPublic exploitFix available

    Heap Out-Of-Bounds Write in Netfilter IP6T_SO_SET_REPLACE

    A heap out-of-bounds write affecting Linux since v2.6.19-rc1 was discovered in net/netfilter/x_tables.c. This allows an attacker to gain privileges or cause a DoS (via heap memory corruption) through user name space

    • Update to 3.13.0-187.238
    Published Updated
  2. CVE-2021-31615

    Medium · CVSS 5.3EPSS 0.4%No fix published

    CVE-2021-31615

    Unencrypted Bluetooth Low Energy baseband links in Bluetooth Core Specifications 4.0 through 5.2 may permit an adjacent device to inject a crafted packet during the receive window of the listening device before the transmitting device initiates its packet transmission to achieve full MITM status without terminating the link. When applied against devices establishing or using encrypted links, crafted packets may be used to terminate an existing link, but will not compromise the confidentiality or integrity of the link.

    Published Updated
  3. CVE-2021-0512

    High · CVSS 7.8EPSS 0.28%No fix published

    CVE-2021-0512

    In __hidinput_change_resolution_multipliers of hid-input.c, there is a possible out of bounds write due to a heap buffer overflow. This could lead to local escalation of privilege with no additional execution privileges needed. User interaction is not needed for exploitation.Product: AndroidVersions: Android kernelAndroid ID: A-173843328References: Upstream kernel

    Published Updated
  4. CVE-2020-10742

    Medium · CVSS 6EPSS 0.26%No fix published

    CVE-2020-10742

    A flaw was found in the Linux kernel. An index buffer overflow during Direct IO write leading to the NFS client to crash. In some cases, a reach out of the index after one memory allocation by kmalloc will cause a kernel panic. The highest threat from this vulnerability is to data confidentiality and system availability.

    Published Updated
  5. CVE-2021-3587

    Not ratedNo fix published

    UBUNTU-CVE-2021-3587

    Rejected reason: DO NOT USE THIS CANDIDATE NUMBER. ConsultIDs: CVE-2021-38208. Reason: This candidate is a reservation duplicate of CVE-2021-38208. Notes: All CVE users should reference CVE-2021-38208 instead of this candidate. All references and descriptions in this candidate have been removed to prevent accidental usage.

    Published Updated
  6. CVE-2021-20292

    Medium · CVSS 6.7EPSS 0.85%No fix published

    CVE-2021-20292

    There is a flaw reported in the Linux kernel in versions before 5.9 in drivers/gpu/drm/nouveau/nouveau_sgdma.c in nouveau_sgdma_create_ttm in Nouveau DRM subsystem. The issue results from the lack of validating the existence of an object prior to performing operations on the object. An attacker with a local account with a root privilege, can leverage this vulnerability to escalate privileges and execute code in the context of the kernel.

    Published Updated
  7. CVE-2020-10774

    Medium · CVSS 5.5EPSS 0.27%No fix published

    CVE-2020-10774

    A memory disclosure flaw was found in the Linux kernel's versions before 4.18.0-193.el8 in the sysctl subsystem when reading the /proc/sys/kernel/rh_features file. This flaw allows a local user to read uninitialized values from the kernel memory. The highest threat from this vulnerability is to confidentiality.

    Published Updated
  8. CVE-2020-27815

    High · CVSS 7.8EPSS 0.79%No fix published

    CVE-2020-27815

    A flaw was found in the JFS filesystem code in the Linux Kernel which allows a local attacker with the ability to set extended attributes to panic the system, causing memory corruption or escalating privileges. The highest threat from this vulnerability is to confidentiality, integrity, as well as system availability.

    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →