p PatchFirst

PatchFirst · Latest vulnerabilities

nodejs vulnerabilities · Page 4

Vulnerabilities published for nodejs in the last 30 days: 9. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 68

  1. CVE-2018-12121

    High · CVSS 7.5EPSS 10.21%No fix published

    CVE-2018-12121

    Node.js: All versions prior to Node.js 6.15.0, 8.14.0, 10.14.0 and 11.3.0: Denial of Service with large HTTP headers: By using a combination of many requests with maximum sized headers (almost 80 KB per connection), and carefully timed completion of the headers, it is possible to cause the HTTP server to abort from heap allocation failure. Attack potential is mitigated by the use of a load balancer or other proxy layer.

    Published Updated
  2. CVE-2018-12115

    High · CVSS 7.5EPSS 7.78%No fix published

    CVE-2018-12115

    In all versions of Node.js prior to 6.14.4, 8.11.4 and 10.9.0 when used with UCS-2 encoding (recognized by Node.js under the names `'ucs2'`, `'ucs-2'`, `'utf16le'` and `'utf-16le'`), `Buffer#write()` can be abused to write outside of the bounds of a single `Buffer`. Writes that start from the second-to-last position of a buffer cause a miscalculation of the maximum length of the input bytes to be written.

    Published Updated
  3. CVE-2018-7159

    Medium · CVSS 5.3EPSS 3.54%No fix published

    CVE-2018-7159

    The HTTP parser in all current versions of Node.js ignores spaces in the `Content-Length` header, allowing input such as `Content-Length: 1 2` to be interpreted as having a value of `12`. The HTTP specification does not allow for spaces in the `Content-Length` value and the Node.js HTTP parser has been brought into line on this particular difference. The security risk of this flaw to Node.js users is considered to be VERY LOW as it is difficult, and may be impossible, to craft an attack that makes use of this flaw in a way that could not already be achieved by supplying an incorrect value for `Content-Length`. Vulnerabilities may exist in use

    Published Updated
  4. CVE-2018-7158

    High · CVSS 7.5EPSS 3.39%No fix published

    CVE-2018-7158

    The `'path'` module in the Node.js 4.x release line contains a potential regular expression denial of service (ReDoS) vector. The code in question was replaced in Node.js 6.x and later so this vulnerability only impacts all versions of Node.js 4.x. The regular expression, `splitPathRe`, used within the `'path'` module for the various path parsing functions, including `path.dirname()`, `path.extname()` and `path.parse()` was structured in such a way as to allow an attacker to craft a string, that when passed through one of these functions, could take a significant amount of time to evaluate, potentially leading to a full denial of service.

    Published Updated
  5. CVE-2016-7099

    Medium · CVSS 5.9EPSS 2.84%Fix available

    CVE-2016-7099

    The tls.checkServerIdentity function in Node.js 0.10.x before 0.10.47, 0.12.x before 0.12.16, 4.x before 4.6.0, and 6.x before 6.7.0 does not properly handle wildcards in name fields of X.509 certificates, which allows man-in-the-middle attackers to spoof servers via a crafted certificate.

    • Update to 0.10.25~dfsg2-2ubuntu1.2+esm1
    Published Updated
  6. CVE-2016-2216

    High · CVSS 7.5EPSS 7.26%No fix published

    CVE-2016-2216

    The HTTP header parsing code in Node.js 0.10.x before 0.10.42, 0.11.6 through 0.11.16, 0.12.x before 0.12.10, 4.x before 4.3.0, and 5.x before 5.6.0 allows remote attackers to bypass an HTTP response-splitting protection mechanism via UTF-8 encoded Unicode characters in the HTTP header, as demonstrated by %c4%8d%c4%8a.

    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →