p PatchFirst

PatchFirst · Latest vulnerabilities

pdns-recursor vulnerabilities · Page 2

Vulnerabilities published for pdns-recursor in the last 30 days: 7. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 62

  1. CVE-2026-33259

    Medium · CVSS 5EPSS 0.22%No fix published

    Concurrent modification of RPZ data can lead to denial of servce

    Having many concurrent transfers of the same RPZ can lead to inconsistent RPZ data, use after free and/or a crash of the recursor. Normally concurrent transfers of the same RPZ zone can only occur with a malfunctioning RPZ provider.

    Published Updated
  2. CVE-2026-33601

    Medium · CVSS 4.4EPSS 0.51%No fix published

    Insufficient validation of zonemd record

    If you use the zoneToCache function with a malicious authoritative server, an attacker can send a zone that result in a null pointer dereference, caused by a missing consistency check and leading to a denial of service.

    Published Updated
  3. CVE-2025-59029

    Medium · CVSS 5.3EPSS 0.37%No fix published

    Internal logic flaw in cache management can lead to a denial of service in PowerDNS Recursor

    An attacker can trigger an assertion failure by requesting crafted DNS records, waiting for them to be inserted into the records cache, then send a query with qtype set to ANY.

    Published Updated
  4. CVE-2025-30192

    High · CVSS 7.5EPSS 0.27%No fix published

    A Recursor configured to send out ECS enabled queries can be sensitive to spoofing attempts

    An attacker spoofing answers to ECS enabled requests sent out by the Recursor has a chance of success higher than non-ECS enabled queries. The updated version include various mitigations against spoofing attempts of ECS enabled queries by chaining ECS enabled requests and enforcing stricter validation of the received answers. The most strict mitigation done when the new setting outgoing.edns_subnet_harden (old style name edns-subnet-harden) is enabled.

    Published Updated
  5. CVE-2025-30195

    High · CVSS 7.5EPSS 0.78%No fix published

    A crafted zone can lead to an illegal memory access in the PowerDNS Recursor

    An attacker can publish a zone containing specific Resource Record Sets. Processing and caching results for these sets can lead to an illegal memory accesses and crash of the Recursor, causing a denial of service. The remedy is: upgrade to the patched 5.2.1 version. We would like to thank Volodymyr Ilyin for bringing this issue to our attention.

    Published Updated
  6. CVE-2024-25583

    High · CVSS 7.5EPSS 0.83%No fix published

    Crafted responses can lead to a denial of service in Recursor if recursive forwarding is configured

    A crafted response from an upstream server the recursor has been configured to forward-recurse to can cause a Denial of Service in the Recursor. The default configuration of the Recursor does not use recursive forwarding and is not affected.

    Published Updated
  7. CVE-2023-50868

    High · CVSS 7.5EPSS 74.3%No fix published

    CVE-2023-50868

    The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance is skipped) allows remote attackers to cause a denial of service (CPU consumption for SHA-1 computations) via DNSSEC responses in a random subdomain attack, aka the "NSEC3" issue. The RFC 5155 specification implies that an algorithm must perform thousands of iterations of a hash function in certain situations.

    Published Updated
  8. CVE-2023-50387

    High · CVSS 7.5EPSS 99.99%No fix published

    CVE-2023-50387

    Certain DNSSEC aspects of the DNS protocol (in RFC 4033, 4034, 4035, 6840, and related RFCs) allow remote attackers to cause a denial of service (CPU consumption) via one or more DNSSEC responses, aka the "KeyTrap" issue. One of the concerns is that, when there is a zone with many DNSKEY and RRSIG records, the protocol specification implies that an algorithm must evaluate all combinations of DNSKEY and RRSIG records.

    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →