p PatchFirst

PatchFirst · Latest vulnerabilities

samba vulnerabilities · Page 2

Vulnerability published for samba in the last 30 days: 1. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 52

  1. CVE-2022-2127

    Medium · CVSS 5.9EPSS 1.72%No fix published

    Samba: out-of-bounds read in winbind auth_crap

    An out-of-bounds read vulnerability was found in Samba due to insufficient length checks in winbindd_pam_auth_crap.c. When performing NTLM authentication, the client replies to cryptographic challenges back to the server. These replies have variable lengths, and Winbind fails to check the lan manager response length. When Winbind is used for NTLM authentication, a maliciously crafted request can trigger an out-of-bounds read in Winbind, possibly resulting in a crash.

    Published Updated
  2. CVE-2022-45141

    Critical · CVSS 9.8EPSS 0.45%Fix available

    CVE-2022-45141

    Since the Windows Kerberos RC4-HMAC Elevation of Privilege Vulnerability was disclosed by Microsoft on Nov 8 2022 and per RFC8429 it is assumed that rc4-hmac is weak, Vulnerable Samba Active Directory DCs will issue rc4-hmac encrypted tickets despite the target server supporting better encryption (eg aes256-cts-hmac-sha1-96).

    • Update to 2:4.3.11+dfsg-0ubuntu0.16.04.34+esm2
    Published Updated
  3. CVE-2022-3437

    Medium · CVSS 4.3EPSS 3.86%Fix available

    CVE-2022-3437

    A heap-based buffer overflow vulnerability was found in Samba within the GSSAPI unwrap_des() and unwrap_des3() routines of Heimdal. The DES and Triple-DES decryption routines in the Heimdal GSSAPI library allow a length-limited write buffer overflow on malloc() allocated memory when presented with a maliciously small packet. This flaw allows a remote user to send specially crafted malicious data to the application, possibly resulting in a denial of service (DoS) attack.

    • Update to 2:4.3.11+dfsg-0ubuntu0.16.04.34+esm2
    Published Updated
  4. CVE-2022-42898

    High · CVSS 8.8EPSS 6.86%Fix available

    CVE-2022-42898

    PAC parsing in MIT Kerberos 5 (aka krb5) before 1.19.4 and 1.20.x before 1.20.1 has integer overflows that may lead to remote code execution (in KDC, kadmind, or a GSS or Kerberos application server) on 32-bit platforms (which have a resultant heap-based buffer overflow), and cause a denial of service on other platforms. This occurs in krb5_pac_parse in lib/krb5/krb/pac.c. Heimdal before 7.7.1 has "a similar bug."

    • Update to 2:4.3.11+dfsg-0ubuntu0.16.04.34+esm2
    Published Updated
  5. CVE-2022-32746

    Medium · CVSS 5.4EPSS 1.31%No fix published

    CVE-2022-32746

    A flaw was found in the Samba AD LDAP server. The AD DC database audit logging module can access LDAP message values freed by a preceding database module, resulting in a use-after-free issue. This issue is only possible when modifying certain privileged attributes, such as userAccountControl.

    Published Updated
  6. CVE-2022-32742

    Medium · CVSS 4.3EPSS 1.31%No fix published

    CVE-2022-32742

    A flaw was found in Samba. Some SMB1 write requests were not correctly range-checked to ensure the client had sent enough data to fulfill the write, allowing server memory contents to be written into the file (or printer) instead of client-supplied data. The client cannot control the area of the server memory written to the file (or printer).

    Published Updated
  7. CVE-2022-2031

    High · CVSS 8.8EPSS 1.26%No fix published

    CVE-2022-2031

    A flaw was found in Samba. The security vulnerability occurs when KDC and the kpasswd service share a single account and set of keys, allowing them to decrypt each other's tickets. A user who has been requested to change their password, can exploit this flaw to obtain and use tickets to other services.

    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →