p PatchFirst

PatchFirst · Latest vulnerabilities

ffmpeg vulnerabilities · Page 5

Vulnerabilities published for ffmpeg in the last 30 days: 10. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 99

  1. USN-6449-2

    Not ratedFix available

    ffmpeg regression

    USN-6449-1 fixed vulnerabilities in FFmpeg. Unfortunately that update could introduce a regression in tools using an FFmpeg library, like VLC. This updated fixes the problem. We apologize for the inconvenience. Original advisory details: It was discovered that FFmpeg incorrectly managed memory resulting in a memory leak. An attacker could possibly use this issue to cause a denial of service via application crash. This issue only affected Ubuntu 18.04 LTS and Ubuntu 20.04 LTS. (CVE-2020-22038) It was discovered that FFmpeg incorrectly handled certain input files, leading to an integer overflow. An attacker could possibly use this iss

    • Update to 7:3.4.11-0ubuntu0.1+esm4
    Published Updated
  2. CVE-2022-48434

    High · CVSS 8.1EPSS 1.52%Fix available

    CVE-2022-48434

    libavcodec/pthread_frame.c in FFmpeg before 5.1.2, as used in VLC and other products, leaves stale hwaccel state in worker threads, which allows attackers to trigger a use-after-free and execute arbitrary code in some circumstances (e.g., hardware re-initialization upon a mid-video SPS change when Direct3D11 is used).

    • Update to 7:3.4.11-0ubuntu0.1+esm3
    Published Updated
  3. CVE-2022-3341

    Medium · CVSS 5.3EPSS 0.86%Fix available

    CVE-2022-3341

    A null pointer dereference issue was discovered in 'FFmpeg' in decode_main_header() function of libavformat/nutdec.c file. The flaw occurs because the function lacks check of the return value of avformat_new_stream() and triggers the null pointer dereference error, causing an application to crash.

    • Update to 7:3.4.11-0ubuntu0.1+esm1
    Published Updated
  4. CVE-2014-5271

    Not ratedEPSS 4.7%No fix published

    CVE-2014-5271

    Heap-based buffer overflow in the encode_slice function in libavcodec/proresenc_kostya.c in FFMpeg before 1.1.14, 1.2.x before 1.2.8, 2.x before 2.2.7, and 2.3.x before 2.3.3 and Libav before 10.5 allows remote attackers to cause a denial of service (crash) or possibly execute arbitrary code via unspecified vectors.

    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →