p PatchFirst

PatchFirst · Latest vulnerabilities

angular.js vulnerabilities · Page 3

Vulnerabilities published for angular.js in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 44

  1. CVE-2023-26117

    Medium · CVSS 5.3EPSS 1.7%Fix available

    CVE-2023-26117

    Versions of the package angular from 1.0.0 are vulnerable to Regular Expression Denial of Service (ReDoS) via the $resource service due to the usage of an insecure regular expression. Exploiting this vulnerability is possible by a large carefully-crafted input, which can result in catastrophic backtracking.

    • Update to 1.7.9-1ubuntu0.1~esm1
    Published Updated
  2. CVE-2022-25844

    Medium · CVSS 5.3EPSS 4.93%Fix available

    Regular Expression Denial of Service (ReDoS)

    The package angular after 1.7.0 are vulnerable to Regular Expression Denial of Service (ReDoS) by providing a custom locale rule that makes it possible to assign the parameter in posPre: ' '.repeat() of NUMBER_FORMATS.PATTERNS[1].posPre with a very high value. **Note:** 1) This package has been deprecated and is no longer maintained. 2) The vulnerable versions are 1.7.0 and higher.

    • Update to 1.7.9-1ubuntu0.1~esm1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →