p PatchFirst

PatchFirst · Latest vulnerabilities

python2.7 vulnerabilities · Page 3

Vulnerabilities published for python2.7 in the last 30 days: 5. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 59

  1. CVE-2025-8291

    Medium · CVSS 4.3EPSS 0.47%No fix published

    ZIP64 End of Central Directory (EOCD) Locator record offset not checked

    The 'zipfile' module would not check the validity of the ZIP64 End of Central Directory (EOCD) Locator record offset value would not be used to locate the ZIP64 EOCD record, instead the ZIP64 EOCD record would be assumed to be the previous record in the ZIP archive. This could be abused to create ZIP archives that are handled differently by the 'zipfile' module compared to other ZIP implementations. Remediation maintains this behavior, but checks that the offset specified in the ZIP64 EOCD Locator record matches the expected value.

    Published Updated
  2. CVE-2025-8194

    High · CVSS 7.5EPSS 0.71%Fix available

    Tarfile infinite loop during parsing with negative member offset

    There is a defect in the CPython “tarfile” module affecting the “TarFile” extraction and entry enumeration APIs. The tar implementation would process tar archives with negative offsets without error, resulting in an infinite loop and deadlock during the parsing of maliciously crafted tar archives. This vulnerability can be mitigated by including the following patch after importing the “tarfile” module:  https://gist.github.com/sethmlarson/1716ac5b82b73dbcbf23ad2eff8b33e1

    • Update to 2.7.18-13ubuntu1.5+esm7
    Published Updated
  3. CVE-2025-0938

    Medium · CVSS 6.3EPSS 1.56%Fix available

    URL parser allowed square brackets in domain names

    The Python standard library functions `urllib.parse.urlsplit` and `urlparse` accepted domain names that included square brackets which isn't valid according to RFC 3986. Square brackets are only meant to be used as delimiters for specifying IPv6 and IPvFuture hosts in URLs. This could result in differential parsing across the Python URL parser and other specification-compliant URL parsers.

    • Update to 2.7.18-13ubuntu1.5+esm6
    Published Updated
  4. CVE-2024-11168

    Medium · CVSS 6.3EPSS 0.66%Fix available

    Improper validation of IPv6 and IPvFuture addresses

    The urllib.parse.urlsplit() and urlparse() functions improperly validated bracketed hosts (`[]`), allowing hosts that weren't IPv6 or IPvFuture. This behavior was not conformant to RFC 3986 and potentially enabled SSRF if a URL is processed by more than one URL parser.

    • Update to 2.7.18-13ubuntu1.5+esm5
    Published Updated
  5. CVE-2024-7592

    High · CVSS 7.5EPSS 2.3%Fix available

    Quadratic complexity parsing cookies with backslashes

    There is a LOW severity vulnerability affecting CPython, specifically the 'http.cookies' standard library module. When parsing cookies that contained backslashes for quoted characters in the cookie value, the parser would use an algorithm with quadratic complexity, resulting in excess CPU resources being used while parsing the value.

    • Update to 2.7.18-13ubuntu1.2+esm2
    Published Updated
  6. CVE-2024-5642

    Medium · CVSS 6.5EPSS 0.74%No fix published

    Buffer overread when using an empty list with SSLContext.set_npn_protocols()

    CPython 3.9 and earlier doesn't disallow configuring an empty list ("[]") for SSLContext.set_npn_protocols() which is an invalid value for the underlying OpenSSL API. This results in a buffer over-read when NPN is used (see CVE-2024-5535 for OpenSSL). This vulnerability is of low severity due to NPN being not widely used and specifying an empty list likely being uncommon in-practice (typically a protocol name would be configured).

    Published Updated
  7. CVE-2024-0397

    High · CVSS 7.4EPSS 0.81%No fix published

    Memory race condition in ssl.SSLContext certificate store methods

    A defect was discovered in the Python “ssl” module where there is a memory race condition with the ssl.SSLContext methods “cert_store_stats()” and “get_ca_certs()”. The race condition can be triggered if the methods are called at the same time as certificates are loaded into the SSLContext, such as during the TLS handshake with a certificate directory configured. This issue is fixed in CPython 3.10.14, 3.11.9, 3.12.3, and 3.13.0a5.

    Published Updated
  8. CVE-2024-0450

    Medium · CVSS 6.2EPSS 0.34%Fix available

    Quoted zip-bomb protection for zipfile

    An issue was found in the CPython `zipfile` module affecting versions 3.12.1, 3.11.7, 3.10.13, 3.9.18, and 3.8.18 and prior. The zipfile module is vulnerable to “quoted-overlap” zip-bombs which exploit the zip format to create a zip-bomb with a high compression ratio. The fixed versions of CPython makes the zipfile module reject zip archives which overlap entries in the archive.

    • Update to 2.7.18-13ubuntu1.5+esm3
    Published Updated
  9. CVE-2023-27043

    Medium · CVSS 5.3EPSS 2.53%Fix available

    CVE-2023-27043

    The email module of Python through 3.11.3 incorrectly parses e-mail addresses that contain a special character. The wrong portion of an RFC2822 header is identified as the value of the addr-spec. In some applications, an attacker can bypass a protection mechanism in which application access is granted only after verifying receipt of e-mail to a specific domain (e.g., only @company.example.com addresses may be used for signup). This occurs in email/_parseaddr.py in recent versions of Python.

    • Update to 2.7.18-13ubuntu1.2+esm3
    Published Updated
  10. CVE-2022-45061

    High · CVSS 7.5EPSS 2.67%Fix available

    CVE-2022-45061

    An issue was discovered in Python before 3.11.1. An unnecessary quadratic algorithm exists in one path when processing some inputs to the IDNA (RFC 3490) decoder, such that a crafted, unreasonably long name being presented to the decoder could lead to a CPU denial of service. Hostnames are often supplied by remote servers that could be controlled by a malicious actor; in such a scenario, they could trigger excessive CPU consumption on the client attempting to make use of an attacker-supplied supposed hostname. For example, the attack payload could be placed in the Location header of an HTTP response with status code 302. A fix is planned in 3

    • Update to 2.7.18-13ubuntu1.5+esm3
    Published Updated
  11. CVE-2021-4189

    Medium · CVSS 5.3EPSS 3.41%Fix available

    CVE-2021-4189

    A flaw was found in Python, specifically in the FTP (File Transfer Protocol) client library in PASV (passive) mode. The issue is how the FTP client trusts the host from the PASV response by default. This flaw allows an attacker to set up a malicious FTP server that can trick FTP clients into connecting back to a given IP address and port. This vulnerability could lead to FTP client scanning ports, which otherwise would not have been possible.

    • Update to 2.7.18-13ubuntu1.1+esm2
    Published Updated
  12. CVE-2022-0391

    High · CVSS 7.5EPSS 8.54%Fix available

    CVE-2022-0391

    A flaw was found in Python, specifically within the urllib.parse module. This module helps break Uniform Resource Locator (URL) strings into components. The issue involves how the urlparse method does not sanitize input and allows characters like '\r' and '\n' in the URL path. This flaw allows an attacker to input a crafted URL, leading to injection attacks. This flaw affects Python versions prior to 3.10.0b1, 3.9.5, 3.8.11, 3.7.11 and 3.6.14.

    • Update to 2.7.18-13ubuntu1.1+esm2
    Published Updated
  13. CVE-2019-17514

    High · CVSS 7.5EPSS 4.67%No fix published

    CVE-2019-17514

    library/glob.html in the Python 2 and 3 documentation before 2016 has potentially misleading information about whether sorting occurs, as demonstrated by irreproducible cancer-research results. NOTE: the effects of this documentation cross application domains, and thus it is likely that security-relevant code elsewhere is affected. This issue is not a Python implementation bug, and there are no reports that NMR researchers were specifically relying on library/glob.html. In other words, because the older documentation stated "finds all the pathnames matching a specified pattern according to the rules used by the Unix shell," one might have inc

    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →