p PatchFirst

USN-5441-1

USN-5441-1 · webkit2gtk vulnerabilities

This page contains facts from public vulnerability sources. Check the original advisory before updating.

A large number of security issues were discovered in the WebKitGTK Web and JavaScript engines. If a user were tricked into viewing a malicious website, a remote attacker could exploit a variety of issues related to web browser security, including cross-site scripting attacks, denial of service attacks, and arbitrary code execution.

Fix available

Published
Updated

Stack: system

Affected products and versions

  • webkit2gtk Ubuntu:20.04:LTS

    Versions
    • 2.26.1-3
    • 2.26.2-1
    • 2.26.3-1ubuntu2
    • 2.26.4-1ubuntu1
    • 2.28.0-1ubuntu2
    • 2.28.1-1
    • 2.28.2-0ubuntu0.20.04.1
    • 2.28.3-0ubuntu0.20.04.1
    • 2.28.4-0ubuntu0.20.04.1
    • 2.30.3-0ubuntu0.20.04.1
    • 2.30.5-0ubuntu0.20.04.1
    • 2.30.6-0ubuntu0.20.04.1
    • 2.32.0-0ubuntu0.20.04.1
    • 2.32.3-0ubuntu0.20.04.1
    • 2.32.4-0ubuntu0.20.04.1
    • 2.34.1-0ubuntu0.20.04.1
    • 2.34.3-0ubuntu0.20.04.1
    • 2.34.4-0ubuntu0.20.04.1
    • 2.34.6-0ubuntu0.20.04.1
    • 2.36.0-0ubuntu0.20.04.3
    Affected ranges
    • ECOSYSTEM: < 2.36.2-0ubuntu0.20.04.1

    Update to 2.36.2-0ubuntu0.20.04.1

  • webkit2gtk Ubuntu:22.04:LTS

    Versions
    • 2.34.0-1ubuntu1
    • 2.34.1-1ubuntu1
    • 2.34.2-1ubuntu1
    • 2.34.3-1
    • 2.35.3-1ubuntu1
    • 2.35.90-1ubuntu1
    • 2.36.0-2ubuntu1
    Affected ranges
    • ECOSYSTEM: < 2.36.2-0ubuntu0.22.04.1

    Update to 2.36.2-0ubuntu0.22.04.1

Original sources

Check your server →