USN-5821-4
USN-5821-4 · python-pip regression
This page contains facts from public vulnerability sources. Check the original advisory before updating.
USN-5821-3 fixed a vulnerability in pip. The update introduced a minor regression in Ubuntu 14.04 ESM, Ubuntu 16.04 ESM and Ubuntu 18.04 LTS. This update fixes the problem. We apologize for the inconvenience. Original advisory details: Sebastian Chnelik discovered that wheel incorrectly handled certain file names when validated against a regex expression. An attacker could possibly use this issue to cause a denial of service.
Fix available
- Published
- Updated
Stack: system
Affected products and versions
python-pip Ubuntu:Pro:14.04:LTS
- Versions
- 1.4.1-2
- 1.5.4-1
- 1.5.4-1ubuntu1
- 1.5.4-1ubuntu3
- 1.5.4-1ubuntu4
- 1.5.4-1ubuntu4+esm1
- 1.5.4-1ubuntu4+esm2
- 1.5.4-1ubuntu4+esm3
- Affected ranges
- ECOSYSTEM: < 1.5.4-1ubuntu4+esm4
Update to 1.5.4-1ubuntu4+esm4
python-pip Ubuntu:Pro:16.04:LTS
- Versions
- 1.5.6-7ubuntu1
- 1.5.6-7ubuntu2
- 8.0.2-7
- 8.0.3-1
- 8.0.3-2
- 8.1.0-1
- 8.1.0-2
- 8.1.1-1
- 8.1.1-2
- 8.1.1-2ubuntu0.1
- 8.1.1-2ubuntu0.2
- 8.1.1-2ubuntu0.4
- 8.1.1-2ubuntu0.6
- 8.1.1-2ubuntu0.6+esm2
- 8.1.1-2ubuntu0.6+esm3
- 8.1.1-2ubuntu0.6+esm4
- Affected ranges
- ECOSYSTEM: < 8.1.1-2ubuntu0.6+esm5
Update to 8.1.1-2ubuntu0.6+esm5
python-pip Ubuntu:18.04:LTS
- Versions
- 9.0.1-2
- 9.0.1-2.3~ubuntu1
- 9.0.1-2.3~ubuntu1.18.04.1
- 9.0.1-2.3~ubuntu1.18.04.2
- 9.0.1-2.3~ubuntu1.18.04.3
- 9.0.1-2.3~ubuntu1.18.04.4
- 9.0.1-2.3~ubuntu1.18.04.5
- 9.0.1-2.3~ubuntu1.18.04.6
- 9.0.1-2.3~ubuntu1.18.04.7
- Affected ranges
- ECOSYSTEM: < 9.0.1-2.3~ubuntu1.18.04.8
Update to 9.0.1-2.3~ubuntu1.18.04.8