p PatchFirst

USN-6156-2

USN-6156-2 · sssd regression

This page contains facts from public vulnerability sources. Check the original advisory before updating.

USN-6156-1 fixed a vulnerability in SSSD. In certain environments, not all packages ended up being upgraded at the same time, resulting in authentication failures when the PAM module was being used. This update fixes the problem. We apologize for the inconvenience. Original advisory details: It was discovered that SSSD incorrrectly sanitized certificate data used in LDAP filters. When using this issue in combination with FreeIPA, a remote attacker could possibly use this issue to escalate privileges.

Fix available

Published
Updated

Stack: system

Affected products and versions

  • sssd Ubuntu:20.04:LTS

    Versions
    • 2.2.0-4ubuntu1
    • 2.2.2-1
    • 2.2.2-1ubuntu1
    • 2.2.3-1.1ubuntu1
    • 2.2.3-2
    • 2.2.3-3
    • 2.2.3-3ubuntu0.1
    • 2.2.3-3ubuntu0.2
    • 2.2.3-3ubuntu0.3
    • 2.2.3-3ubuntu0.4
    • 2.2.3-3ubuntu0.6
    • 2.2.3-3ubuntu0.7
    • 2.2.3-3ubuntu0.8
    • 2.2.3-3ubuntu0.9
    • 2.2.3-3ubuntu0.10
    • 2.2.3-3ubuntu0.11
    Affected ranges
    • ECOSYSTEM: < 2.2.3-3ubuntu0.12

    Update to 2.2.3-3ubuntu0.12

Original sources

Check your server →