USN-6508-2
USN-6508-2 · poppler regression
This page contains facts from public vulnerability sources. Check the original advisory before updating.
USN-6508-1 fixed vulnerabilities in poppler. The update introduced one minor regression in Ubuntu 18.04 LTS. This update fixes the problem. We apologize for the inconvenience. Original advisory details: It was discovered that poppler incorrectly handled certain malformed PDF files. If a user or an automated system were tricked into opening a specially crafted PDF file, a remote attacker could possibly use this issue to cause a denial of service. This issue only affected Ubuntu 16.04 LTS, Ubuntu 18.04 LTS and Ubuntu 20.04 LTS. (CVE-2020-23804) It was discovered that poppler incorrectly handled certain malformed PDF files. If a user or an automated system were tricked into opening a specially crafted PDF file, a remote attacker could possibly use this issue to cause a denial of service. (CVE-2022-37050, CVE-2022-37051, CVE-2022-37052, CVE-2022-38349)
Fix available
- Published
- Updated
Stack: system
Affected products and versions
poppler Ubuntu:Pro:18.04:LTS
- Versions
- 0.57.0-2ubuntu4
- 0.57.0-2ubuntu5
- 0.62.0-1ubuntu1
- 0.62.0-2ubuntu1
- 0.62.0-2ubuntu2
- 0.62.0-2ubuntu2.1
- 0.62.0-2ubuntu2.2
- 0.62.0-2ubuntu2.4
- 0.62.0-2ubuntu2.5
- 0.62.0-2ubuntu2.6
- 0.62.0-2ubuntu2.7
- 0.62.0-2ubuntu2.8
- 0.62.0-2ubuntu2.9
- 0.62.0-2ubuntu2.10
- 0.62.0-2ubuntu2.11
- 0.62.0-2ubuntu2.12
- 0.62.0-2ubuntu2.13
- 0.62.0-2ubuntu2.14
- 0.62.0-2ubuntu2.14+esm1
- 0.62.0-2ubuntu2.14+esm2
- Affected ranges
- ECOSYSTEM: < 0.62.0-2ubuntu2.14+esm3
Update to 0.62.0-2ubuntu2.14+esm3