p PatchFirst

USN-6844-2

USN-6844-2 · cups regression

This page contains facts from public vulnerability sources. Check the original advisory before updating.

USN-6844-1 fixed vulnerabilities in the CUPS package. The update lead to the discovery of a regression in CUPS with regards to how the cupsd daemon handles Listen configuration directive. This update fixes the problem. We apologize for the inconvenience. Original advisory details: Rory McNamara discovered that when starting the cupsd server with a Listen configuration item, the cupsd process fails to validate if bind call passed. An attacker could possibly trick cupsd to perform an arbitrary chmod of the provided argument, providing world-writable access to the target.

Fix available

Published
Updated

Stack: system

Affected products and versions

  • cups Ubuntu:Pro:16.04:LTS

    Versions
    • 2.1.0-4ubuntu3
    • 2.1.0-5
    • 2.1.0-6
    • 2.1.0-6ubuntu1
    • 2.1.0-7
    • 2.1.2-1
    • 2.1.2-2
    • 2.1.3-1
    • 2.1.3-1build1
    • 2.1.3-3
    • 2.1.3-4
    • 2.1.3-4ubuntu0.2
    • 2.1.3-4ubuntu0.3
    • 2.1.3-4ubuntu0.4
    • 2.1.3-4ubuntu0.5
    • 2.1.3-4ubuntu0.6
    • 2.1.3-4ubuntu0.7
    • 2.1.3-4ubuntu0.8
    • 2.1.3-4ubuntu0.9
    • 2.1.3-4ubuntu0.10
    • 2.1.3-4ubuntu0.11
    • 2.1.3-4ubuntu0.11+esm1
    • 2.1.3-4ubuntu0.11+esm2
    • 2.1.3-4ubuntu0.11+esm3
    • 2.1.3-4ubuntu0.11+esm4
    • 2.1.3-4ubuntu0.11+esm5
    • 2.1.3-4ubuntu0.11+esm6
    Affected ranges
    • ECOSYSTEM: < 2.1.3-4ubuntu0.11+esm7

    Update to 2.1.3-4ubuntu0.11+esm7

  • cups Ubuntu:Pro:18.04:LTS

    Versions
    • 2.2.4-7ubuntu2
    • 2.2.5-2
    • 2.2.6-2
    • 2.2.6-3
    • 2.2.6-4
    • 2.2.6-5
    • 2.2.7-1ubuntu1
    • 2.2.7-1ubuntu2
    • 2.2.7-1ubuntu2.1
    • 2.2.7-1ubuntu2.2
    • 2.2.7-1ubuntu2.3
    • 2.2.7-1ubuntu2.4
    • 2.2.7-1ubuntu2.5
    • 2.2.7-1ubuntu2.6
    • 2.2.7-1ubuntu2.7
    • 2.2.7-1ubuntu2.8
    • 2.2.7-1ubuntu2.9
    • 2.2.7-1ubuntu2.10
    • 2.2.7-1ubuntu2.10+esm1
    • 2.2.7-1ubuntu2.10+esm2
    • 2.2.7-1ubuntu2.10+esm3
    • 2.2.7-1ubuntu2.10+esm4
    Affected ranges
    • ECOSYSTEM: < 2.2.7-1ubuntu2.10+esm5

    Update to 2.2.7-1ubuntu2.10+esm5

  • cups Ubuntu:20.04:LTS

    Versions
    • 2.2.12-2ubuntu1
    • 2.3.0-6
    • 2.3.0-7
    • 2.3.0-7ubuntu1
    • 2.3.1-1ubuntu1
    • 2.3.1-2
    • 2.3.1-4
    • 2.3.1-7
    • 2.3.1-9ubuntu1
    • 2.3.1-9ubuntu1.1
    • 2.3.1-9ubuntu1.2
    • 2.3.1-9ubuntu1.3
    • 2.3.1-9ubuntu1.4
    • 2.3.1-9ubuntu1.5
    • 2.3.1-9ubuntu1.6
    • 2.3.1-9ubuntu1.7
    Affected ranges
    • ECOSYSTEM: < 2.3.1-9ubuntu1.8

    Update to 2.3.1-9ubuntu1.8

  • cups Ubuntu:22.04:LTS

    Versions
    • 2.3.3op2-7ubuntu2
    • 2.4.1op1-1ubuntu1
    • 2.4.1op1-1ubuntu2
    • 2.4.1op1-1ubuntu3
    • 2.4.1op1-1ubuntu4
    • 2.4.1op1-1ubuntu4.1
    • 2.4.1op1-1ubuntu4.2
    • 2.4.1op1-1ubuntu4.4
    • 2.4.1op1-1ubuntu4.6
    • 2.4.1op1-1ubuntu4.7
    • 2.4.1op1-1ubuntu4.8
    • 2.4.1op1-1ubuntu4.9
    Affected ranges
    • ECOSYSTEM: < 2.4.1op1-1ubuntu4.10

    Update to 2.4.1op1-1ubuntu4.10

  • cups Ubuntu:24.04:LTS

    Versions
    • 2.4.6-0ubuntu3
    • 2.4.7-1.2ubuntu2
    • 2.4.7-1.2ubuntu3
    • 2.4.7-1.2ubuntu7
    • 2.4.7-1.2ubuntu7.1
    Affected ranges
    • ECOSYSTEM: < 2.4.7-1.2ubuntu7.2

    Update to 2.4.7-1.2ubuntu7.2

Original sources

Check your server →