USN-6846-2
USN-6846-2 · ansible regression
This page contains facts from public vulnerability sources. Check the original advisory before updating.
USN-6846-1 fixed vulnerabilities in ansible. The update introduced a regression in ansible. This update fixes the problem. We apologize for the inconvenience. Original advisory details: It was discovered that Ansible incorrectly handled certain inputs when using tower_callback parameter. If a user or an automated system were tricked into opening a specially crafted input file, a remote attacker could possibly use this issue to obtain sensitive information. This issue only affected Ubuntu 18.04 LTS, Ubuntu 20.04 LTS, and Ubuntu 22.04 LTS. (CVE-2022-3697) It was discovered that Ansible incorrectly handled certain inputs. If a user or an automated system were tricked into opening a specially crafted input file, a remote attacker could possibly use this issue to perform a Template Injection. (CVE-2023-5764)
Fix available
- Published
- Updated
Stack: system
Affected products and versions
ansible Ubuntu:Pro:16.04:LTS
- Versions
- 1.9.2+dfsg-2
- 1.9.4-1
- 2.0.0.2-2
- 2.0.0.2-2ubuntu1
- 2.0.0.2-2ubuntu1.1
- 2.0.0.2-2ubuntu1.2
- 2.0.0.2-2ubuntu1.3
- 2.0.0.2-2ubuntu1.3+esm1
- 2.0.0.2-2ubuntu1.3+esm2
- Affected ranges
- ECOSYSTEM: < 2.0.0.2-2ubuntu1.3+esm3
Update to 2.0.0.2-2ubuntu1.3+esm3
ansible Ubuntu:Pro:18.04:LTS
- Versions
- 2.3.1.0+dfsg-2
- 2.5.0+dfsg-1
- 2.5.1+dfsg-1
- 2.5.1+dfsg-1ubuntu0.1
- 2.5.1+dfsg-1ubuntu0.1+esm1
- 2.5.1+dfsg-1ubuntu0.1+esm2
- Affected ranges
- ECOSYSTEM: < 2.5.1+dfsg-1ubuntu0.1+esm3
Update to 2.5.1+dfsg-1ubuntu0.1+esm3