p PatchFirst

PatchFirst · Aktuelle Sicherheitslücken

Sicherheitslücken in lighttpd

In den letzten 30 Tagen veröffentlichte Sicherheitslücken für lighttpd: 0. Davon im KEV-Katalog: 0.

Sicherheitslücken filtern
Filter zurücksetzen

Sicherheitslücken: 5

  1. ALPINE-CVE-2025-8671

    Hoch · CVSS 7.5Korrektur verfügbar

    ALPINE-CVE-2025-8671

    A mismatch caused by client-triggered server-sent stream resets between HTTP/2 specifications and the internal architectures of some HTTP/2 implementations may result in excessive server resource consumption leading to denial-of-service (DoS). By opening streams and then rapidly triggering the server to reset them—using malformed frames or flow control errors—an attacker can exploit incorrect stream accounting. Streams reset by the server are considered closed at the protocol level, even though backend processing continues. This allows a client to cause the server to handle an unbounded number of concurrent streams on a single connection. Th

    • Auf 0-r0 aktualisieren
    Veröffentlicht Aktualisiert
  2. ALPINE-CVE-2024-3094

    Kritisch · CVSS 10Korrektur verfügbar

    ALPINE-CVE-2024-3094

    Malicious code was discovered in the upstream tarballs of xz, starting with version 5.6.0. Through a series of complex obfuscations, the liblzma build process extracts a prebuilt object file from a disguised test file existing in the source code, which is then used to modify specific functions in the liblzma code. This results in a modified liblzma library that can be used by any software linked against this library, intercepting and modifying the data interaction with this library.

    • Auf 1.4.76-r0 aktualisieren
    Veröffentlicht Aktualisiert
  3. ALPINE-CVE-2022-41556

    Hoch · CVSS 7.5Korrektur verfügbar

    ALPINE-CVE-2022-41556

    A resource leak in gw_backend.c in lighttpd 1.4.56 through 1.4.66 could lead to a denial of service (connection-slot exhaustion) after a large amount of anomalous TCP behavior by clients. It is related to RDHUP mishandling in certain HTTP/1.1 chunked situations. Use of mod_fastcgi is, for example, affected. This is fixed in 1.4.67.

    • Auf 1.4.67-r0 aktualisieren
    Veröffentlicht Aktualisiert
  4. ALPINE-CVE-2022-22707

    Mittel · CVSS 5.9Korrektur verfügbar

    ALPINE-CVE-2022-22707

    In lighttpd 1.4.46 through 1.4.63, the mod_extforward_Forwarded function of the mod_extforward plugin has a stack-based buffer overflow (4 bytes representing -1), as demonstrated by remote denial of service (daemon crash) in a non-default configuration. The non-default configuration requires handling of the Forwarded header in a somewhat unusual manner. Also, a 32-bit system is much more likely to be affected than a 64-bit system.

    • Auf 1.4.64-r0 aktualisieren
    Veröffentlicht Aktualisiert

Prüfen Sie Ihren Server

Gleichen Sie Ihren installierten Stack und seine Versionen mit den aktuellen Sicherheitsmeldungen ab.

Prüfen Sie Ihren Server →