p PatchFirst

PatchFirst · Aktuelle Sicherheitslücken

Sicherheitslücken in brotli

In den letzten 30 Tagen veröffentlichte Sicherheitslücke für brotli: 1. Davon im KEV-Katalog: 0.

Sicherheitslücken filtern
Filter zurücksetzen

Sicherheitslücken: 2

  1. ALPINE-CVE-2026-111497

    Kritisch · CVSS 9.2Korrektur verfügbar

    ALPINE-CVE-2026-111497

    A buffer overflow vulnerability in the Brotli decoder (c/dec/decode.c) in Google Brotli versions 1.0.3 through 1.2.0 on all platforms allows a remote unauthenticated attacker to corrupt adjacent decoder state memory, disclose sensitive memory contents, cause a denial of service, or potentially execute arbitrary code using a crafted Brotli-compressed stream. Users need to update any Brotli libraries or binaries between 1.0.3 through 1.2.0 to the latest available version: 1.0.10 or 1.1.1 or 1.2.1.

    • Auf 1.2.1-r0 aktualisieren
    Veröffentlicht Aktualisiert
  2. ALPINE-CVE-2020-8927

    Mittel · CVSS 6.5Korrektur verfügbar

    ALPINE-CVE-2020-8927

    A buffer overflow exists in the Brotli library versions prior to 1.0.8 where an attacker controlling the input length of a "one-shot" decompression request to a script can trigger a crash, which happens when copying over chunks of data larger than 2 GiB. It is recommended to update your Brotli library to 1.0.8 or later. If one cannot update, we recommend to use the "streaming" API as opposed to the "one-shot" API, and impose chunk size limits.

    • Auf 1.0.9-r0 aktualisieren
    Veröffentlicht Aktualisiert

Prüfen Sie Ihren Server

Gleichen Sie Ihren installierten Stack und seine Versionen mit den aktuellen Sicherheitsmeldungen ab.

Prüfen Sie Ihren Server →