p PatchFirst

ALPINE-CVE-2020-8927

ALPINE-CVE-2020-8927

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

A buffer overflow exists in the Brotli library versions prior to 1.0.8 where an attacker controlling the input length of a "one-shot" decompression request to a script can trigger a crash, which happens when copying over chunks of data larger than 2 GiB. It is recommended to update your Brotli library to 1.0.8 or later. If one cannot update, we recommend to use the "streaming" API as opposed to the "one-shot" API, and impose chunk size limits.

CVSS 6.5 · Mittel · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system

Betroffene Produkte und Versionen

  • brotli Alpine:v3.12

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.0.9-r0

    Auf 1.0.9-r0 aktualisieren

  • brotli Alpine:v3.13

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.0.9-r0

    Auf 1.0.9-r0 aktualisieren

  • brotli Alpine:v3.14

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.0.9-r0

    Auf 1.0.9-r0 aktualisieren

  • brotli Alpine:v3.15

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.0.9-r0

    Auf 1.0.9-r0 aktualisieren

  • brotli Alpine:v3.16

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.0.9-r0

    Auf 1.0.9-r0 aktualisieren

  • brotli Alpine:v3.17

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.0.9-r0

    Auf 1.0.9-r0 aktualisieren

  • brotli Alpine:v3.18

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.0.9-r0

    Auf 1.0.9-r0 aktualisieren

  • brotli Alpine:v3.19

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.0.9-r0

    Auf 1.0.9-r0 aktualisieren

  • brotli Alpine:v3.20

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.0.9-r0

    Auf 1.0.9-r0 aktualisieren

  • brotli Alpine:v3.21

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.0.9-r0

    Auf 1.0.9-r0 aktualisieren

  • brotli Alpine:v3.22

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.0.9-r0

    Auf 1.0.9-r0 aktualisieren

  • brotli Alpine:v3.23

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.0.9-r0

    Auf 1.0.9-r0 aktualisieren

  • brotli Alpine:v3.24

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.0.9-r0

    Auf 1.0.9-r0 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →