p PatchFirst

CVE-2017-20165

CVE-2017-20165 · debug-js debug node.js useColors redos

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

A vulnerability classified as problematic has been found in debug-js debug up to 3.0.x. This affects the function useColors of the file src/node.js. The manipulation of the argument str leads to inefficient regular expression complexity. Upgrading to version 3.1.0 is able to address this issue. The identifier of the patch is c38a0166c266a679c8de012d4eaccec3f944e685. It is recommended to upgrade the affected component. The identifier VDB-217665 was assigned to this vulnerability.

CVSS 3.5 · Niedrig · EPSS 2,1% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system · node

Betroffene Produkte und Versionen

  • debug

    Softwareversionen
    • 3.0: Betroffen

    Keine Korrektur veröffentlicht

  • node-debug Debian:12

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 3.1.0-1

    Auf 3.1.0-1 aktualisieren

  • node-debug Debian:13

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 3.1.0-1

    Auf 3.1.0-1 aktualisieren

  • node-debug Debian:14

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 3.1.0-1

    Auf 3.1.0-1 aktualisieren

  • debug npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 3.0.0, < 3.1.0

    Auf 3.1.0 aktualisieren

  • debug npm

    Betroffene Versionsbereiche
    • SEMVER: < 2.6.9

    Auf 2.6.9 aktualisieren

  • node-debug Ubuntu:16.04:LTS

    Softwareversionen
    • 2.1.0+dfsg-2
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-debug Ubuntu:18.04:LTS

    Softwareversionen
    • 2.5.1-2
    • 3.1.0-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

Originalquellen

Prüfen Sie Ihren Server →