p PatchFirst

CVE-2018-1000180

CVE-2018-1000180

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

Bouncy Castle BC 1.54 - 1.59, BC-FJA 1.0.0, BC-FJA 1.0.1 and earlier have a flaw in the Low-level interface to RSA key pair generator, specifically RSA Key Pairs generated in low-level API with added certainty may have less M-R tests than expected. This appears to be fixed in versions BC 1.60 beta 4 and later, BC-FJA 1.0.2 and later.

CVSS 7.5 · Hoch · EPSS 3,4% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system

Betroffene Produkte und Versionen

  • n/a

    Softwareversionen
    • n/a: Betroffen

    Keine Korrektur veröffentlicht

  • bouncycastle Debian:12

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.59-2

    Auf 1.59-2 aktualisieren

  • bouncycastle Debian:13

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.59-2

    Auf 1.59-2 aktualisieren

  • bouncycastle Debian:14

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.59-2

    Auf 1.59-2 aktualisieren

  • bouncycastle Ubuntu:Pro:18.04:LTS

    Softwareversionen
    • 1.57-1
    • 1.58-1
    • 1.59-1
    • 1.59-1ubuntu0.1~esm1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

Originalquellen

Prüfen Sie Ihren Server →