p PatchFirst

CVE-2018-1000180

CVE-2018-1000180

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Bouncy Castle BC 1.54 - 1.59, BC-FJA 1.0.0, BC-FJA 1.0.1 and earlier have a flaw in the Low-level interface to RSA key pair generator, specifically RSA Key Pairs generated in low-level API with added certainty may have less M-R tests than expected. This appears to be fixed in versions BC 1.60 beta 4 and later, BC-FJA 1.0.2 and later.

CVSS 7.5 · High · EPSS 3.4% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • bouncycastle Debian:12

    Affected ranges
    • ECOSYSTEM: < 1.59-2

    Update to 1.59-2

  • bouncycastle Debian:13

    Affected ranges
    • ECOSYSTEM: < 1.59-2

    Update to 1.59-2

  • bouncycastle Debian:14

    Affected ranges
    • ECOSYSTEM: < 1.59-2

    Update to 1.59-2

  • bouncycastle Ubuntu:Pro:18.04:LTS

    Versions
    • 1.57-1
    • 1.58-1
    • 1.59-1
    • 1.59-1ubuntu0.1~esm1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

Original sources

Check your server →