p PatchFirst

CVE-2018-16476

CVE-2018-16476

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

A Broken Access Control vulnerability in Active Job versions >= 4.2.0 allows an attacker to craft user input which can cause Active Job to deserialize it using GlobalId and give them access to information that they should not have. This vulnerability has been fixed in versions 4.2.11, 5.0.7.1, 5.1.6.1, and 5.2.1.1.

CVSS 7.5 · Hoch · EPSS 2,9% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system

Betroffene Produkte und Versionen

  • https://github.com/rails/rails

    Softwareversionen
    • 4.2.0 up to and before 4.2.11: Betroffen
    • 4.2.0 up to and before 5.0.7.1: Betroffen
    • 4.2.0 up to and before 5.1.6.1: Betroffen
    • 4.2.0 up to and before 5.2.1.1: Betroffen

    Keine Korrektur veröffentlicht

  • rails Debian:12

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2:5.2.2+dfsg-1

    Auf 2:5.2.2+dfsg-1 aktualisieren

  • rails Debian:13

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2:5.2.2+dfsg-1

    Auf 2:5.2.2+dfsg-1 aktualisieren

  • rails Debian:14

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2:5.2.2+dfsg-1

    Auf 2:5.2.2+dfsg-1 aktualisieren

  • rails Ubuntu:Pro:16.04:LTS

    Softwareversionen
    • 2:4.1.10-1
    • 2:4.2.5-1
    • 2:4.2.5.1-1
    • 2:4.2.5.2-2
    • 2:4.2.6-1
    • 2:4.2.6-1ubuntu0.1~esm1
    • 2:4.2.6-1ubuntu0.1~esm2
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • rails Ubuntu:Pro:18.04:LTS

    Softwareversionen
    • 2:4.2.9-2
    • 2:4.2.9-4
    • 2:4.2.10-0ubuntu4
    • 2:4.2.10-0ubuntu4+esm1
    • 2:4.2.10-0ubuntu4+esm2
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • rails Ubuntu:Pro:20.04:LTS

    Softwareversionen
    • 2:5.2.2.1+dfsg-1ubuntu1
    • 2:5.2.3+dfsg-3
    • 2:5.2.3+dfsg-3ubuntu0.1~esm1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • rails Ubuntu:Pro:22.04:LTS

    Softwareversionen
    • 2:6.0.3.7+dfsg-2
    • 2:6.1.4.1+dfsg-8ubuntu2
    • 2:6.1.4.1+dfsg-8ubuntu2+esm1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

Originalquellen

Prüfen Sie Ihren Server →