CVE-2018-16476
CVE-2018-16476
This page contains facts from public vulnerability sources. Check the original advisory before updating.
A Broken Access Control vulnerability in Active Job versions >= 4.2.0 allows an attacker to craft user input which can cause Active Job to deserialize it using GlobalId and give them access to information that they should not have. This vulnerability has been fixed in versions 4.2.11, 5.0.7.1, 5.1.6.1, and 5.2.1.1.
CVSS 7.5 · High · EPSS 2.9% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
https://github.com/rails/rails
- Versions
- 4.2.0 up to and before 4.2.11: Affected
- 4.2.0 up to and before 5.0.7.1: Affected
- 4.2.0 up to and before 5.1.6.1: Affected
- 4.2.0 up to and before 5.2.1.1: Affected
No fix published
rails Debian:12
- Affected ranges
- ECOSYSTEM: < 2:5.2.2+dfsg-1
Update to 2:5.2.2+dfsg-1
rails Debian:13
- Affected ranges
- ECOSYSTEM: < 2:5.2.2+dfsg-1
Update to 2:5.2.2+dfsg-1
rails Debian:14
- Affected ranges
- ECOSYSTEM: < 2:5.2.2+dfsg-1
Update to 2:5.2.2+dfsg-1
rails Ubuntu:Pro:16.04:LTS
- Versions
- 2:4.1.10-1
- 2:4.2.5-1
- 2:4.2.5.1-1
- 2:4.2.5.2-2
- 2:4.2.6-1
- 2:4.2.6-1ubuntu0.1~esm1
- 2:4.2.6-1ubuntu0.1~esm2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
rails Ubuntu:Pro:18.04:LTS
- Versions
- 2:4.2.9-2
- 2:4.2.9-4
- 2:4.2.10-0ubuntu4
- 2:4.2.10-0ubuntu4+esm1
- 2:4.2.10-0ubuntu4+esm2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
rails Ubuntu:Pro:20.04:LTS
- Versions
- 2:5.2.2.1+dfsg-1ubuntu1
- 2:5.2.3+dfsg-3
- 2:5.2.3+dfsg-3ubuntu0.1~esm1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
rails Ubuntu:Pro:22.04:LTS
- Versions
- 2:6.0.3.7+dfsg-2
- 2:6.1.4.1+dfsg-8ubuntu2
- 2:6.1.4.1+dfsg-8ubuntu2+esm1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published