CVE-2019-10163
CVE-2019-10163
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
A Vulnerability has been found in PowerDNS Authoritative Server before versions 4.1.9, 4.0.8 allowing a remote, authorized master server to cause a high CPU load or even prevent any further updates to any slave zone by sending a large number of NOTIFY messages. Note that only servers configured as slaves are affected by this issue.
CVSS 3.5 · Niedrig · EPSS 1,0% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system
Betroffene Produkte und Versionen
pdns
- Softwareversionen
- fixed in 4.1.9: Betroffen
- fixed in 4.0.8: Betroffen
Keine Korrektur veröffentlicht
pdns Debian:12
- Betroffene Versionsbereiche
- ECOSYSTEM: < 4.1.6-3
Auf 4.1.6-3 aktualisieren
pdns Debian:13
- Betroffene Versionsbereiche
- ECOSYSTEM: < 4.1.6-3
Auf 4.1.6-3 aktualisieren
pdns Debian:14
- Betroffene Versionsbereiche
- ECOSYSTEM: < 4.1.6-3
Auf 4.1.6-3 aktualisieren
pdns Ubuntu:Pro:16.04:LTS
- Softwareversionen
- 3.4.5-1build2
- 3.4.6-2
- 3.4.6-3
- 3.4.7-1
- 3.4.7-2
- 4.0.0~alpha1-1
- 4.0.0~alpha2-2
- 4.0.0~alpha2-3
- 4.0.0~alpha2-3build1
- 4.0.0~alpha2-3ubuntu0.1~esm1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
pdns Ubuntu:Pro:18.04:LTS
- Softwareversionen
- 4.0.4-2
- 4.0.4-2build1
- 4.0.5-1
- 4.1.0-1
- 4.1.0-2
- 4.1.0-2build1
- 4.1.1-1
- 4.1.1-1ubuntu0.1~esm1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
Originalquellen
- http://lists.opensuse.org/opensuse-security-announce/2019-08/msg00036.html
- http://lists.opensuse.org/opensuse-security-announce/2019-08/msg00054.html
- https://blog.powerdns.com/2019/06/21/powerdns-authoritative-server-4-0-8-and-4-1-10-released/
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-10163
- https://doc.powerdns.com/authoritative/security-advisories/powerdns-advisory-2019-05.html
- https://nvd.nist.gov/vuln/detail/CVE-2019-10163