p PatchFirst

CVE-2019-12472

CVE-2019-12472

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

An Incorrect Access Control vulnerability was found in Wikimedia MediaWiki 1.18.0 through 1.32.1. It is possible to bypass the limits on IP range blocks ($wgBlockCIDRLimit) by using the API. Fixed in 1.32.2, 1.31.2, 1.30.2 and 1.27.6.

CVSS 7.5 · Hoch · EPSS 1,3% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system · php

Betroffene Produkte und Versionen

  • n/a

    Softwareversionen
    • n/a: Betroffen

    Keine Korrektur veröffentlicht

  • mediawiki Debian:12

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1:1.31.2-1

    Auf 1:1.31.2-1 aktualisieren

  • mediawiki Debian:13

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1:1.31.2-1

    Auf 1:1.31.2-1 aktualisieren

  • mediawiki Debian:14

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1:1.31.2-1

    Auf 1:1.31.2-1 aktualisieren

  • mediawiki/core Packagist

    Softwareversionen
    • 1.20.3
    • 1.20.4
    • 1.20.5
    • 1.20.6
    • 1.20.7
    • 1.20.8
    • 1.21.0
    • 1.21.1
    • 1.21.10
    • 1.21.11
    • 1.21.2
    • 1.21.3
    • 1.21.4
    • 1.21.5
    • 1.21.6
    • 1.21.7
    • 1.21.8
    • 1.21.9
    • 1.22.0rc0
    • 1.24.0
    • 1.24.0-rc.0
    • 1.24.0-rc.1
    • 1.24.0-rc.2
    • 1.24.0-rc.3
    • 1.24.1
    • 1.24.2
    • 1.24.3
    • 1.24.4
    • 1.24.5
    • 1.24.6
    • 1.25.0
    • 1.25.0-rc.0
    • 1.25.1
    • 1.25.2
    • 1.25.3
    • 1.25.4
    • 1.25.5
    • 1.25.6
    • 1.26.0
    • 1.26.1
    • 1.26.2
    • 1.26.3
    • 1.26.4
    • 1.27.0
    • 1.27.0-rc.0
    • 1.27.0-rc.1
    • 1.27.1
    • 1.27.2
    • 1.27.3
    • 1.27.4
    • 1.27.5
    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 1.18.0, < 1.27.6

    Auf 1.27.6 aktualisieren

  • mediawiki/core Packagist

    Softwareversionen
    • 1.30.0
    • 1.30.1
    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 1.30.0, < 1.30.2

    Auf 1.30.2 aktualisieren

  • mediawiki/core Packagist

    Softwareversionen
    • 1.31.0
    • 1.31.1
    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 1.31.0, < 1.31.2

    Auf 1.31.2 aktualisieren

  • mediawiki/core Packagist

    Softwareversionen
    • 1.32.0
    • 1.32.1
    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 1.32.0, < 1.32.2

    Auf 1.32.2 aktualisieren

  • mediawiki Ubuntu:18.04:LTS

    Softwareversionen
    • 1:1.27.3-1
    • 1:1.27.4-1
    • 1:1.27.4-2
    • 1:1.27.4-3
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

Originalquellen

Prüfen Sie Ihren Server →