CVE-2019-12472
CVE-2019-12472
This page contains facts from public vulnerability sources. Check the original advisory before updating.
An Incorrect Access Control vulnerability was found in Wikimedia MediaWiki 1.18.0 through 1.32.1. It is possible to bypass the limits on IP range blocks ($wgBlockCIDRLimit) by using the API. Fixed in 1.32.2, 1.31.2, 1.30.2 and 1.27.6.
CVSS 7.5 · High · EPSS 1.3% · Fix available
- Published
- Updated
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
mediawiki Debian:12
- Affected ranges
- ECOSYSTEM: < 1:1.31.2-1
Update to 1:1.31.2-1
mediawiki Debian:13
- Affected ranges
- ECOSYSTEM: < 1:1.31.2-1
Update to 1:1.31.2-1
mediawiki Debian:14
- Affected ranges
- ECOSYSTEM: < 1:1.31.2-1
Update to 1:1.31.2-1
mediawiki/core Packagist
- Versions
- 1.20.3
- 1.20.4
- 1.20.5
- 1.20.6
- 1.20.7
- 1.20.8
- 1.21.0
- 1.21.1
- 1.21.10
- 1.21.11
- 1.21.2
- 1.21.3
- 1.21.4
- 1.21.5
- 1.21.6
- 1.21.7
- 1.21.8
- 1.21.9
- 1.22.0rc0
- 1.24.0
- 1.24.0-rc.0
- 1.24.0-rc.1
- 1.24.0-rc.2
- 1.24.0-rc.3
- 1.24.1
- 1.24.2
- 1.24.3
- 1.24.4
- 1.24.5
- 1.24.6
- 1.25.0
- 1.25.0-rc.0
- 1.25.1
- 1.25.2
- 1.25.3
- 1.25.4
- 1.25.5
- 1.25.6
- 1.26.0
- 1.26.1
- 1.26.2
- 1.26.3
- 1.26.4
- 1.27.0
- 1.27.0-rc.0
- 1.27.0-rc.1
- 1.27.1
- 1.27.2
- 1.27.3
- 1.27.4
- 1.27.5
- Affected ranges
- ECOSYSTEM: ≥ 1.18.0, < 1.27.6
Update to 1.27.6
mediawiki/core Packagist
- Versions
- 1.30.0
- 1.30.1
- Affected ranges
- ECOSYSTEM: ≥ 1.30.0, < 1.30.2
Update to 1.30.2
mediawiki/core Packagist
- Versions
- 1.31.0
- 1.31.1
- Affected ranges
- ECOSYSTEM: ≥ 1.31.0, < 1.31.2
Update to 1.31.2
mediawiki/core Packagist
- Versions
- 1.32.0
- 1.32.1
- Affected ranges
- ECOSYSTEM: ≥ 1.32.0, < 1.32.2
Update to 1.32.2
mediawiki Ubuntu:18.04:LTS
- Versions
- 1:1.27.3-1
- 1:1.27.4-1
- 1:1.27.4-2
- 1:1.27.4-3
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published