p PatchFirst

CVE-2020-26211

CVE-2020-26211 · Cross-Site Scripting in BookStack

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

In BookStack before version 0.30.4, a user with permissions to edit a page could insert JavaScript code through the use of `javascript:` URIs within a link or form which would run, within the context of the current page, when clicked or submitted. Additionally, a user with permissions to edit a page could insert a particular meta tag which could be used to silently redirect users to a alternative location upon visit of a page. Dangerous content may remain in the database but will be removed before being displayed on a page. If you think this could have been exploited the linked advisory provides a SQL query to test. As a workaround without upgrading, page edit permissions could be limited to only those that are trusted until you can upgrade although this will not address existing exploitation of this vulnerability. The issue is fixed in BookStack version 0.30.4.

CVSS 7.7 · Hoch · EPSS 1,1% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: php

Betroffene Produkte und Versionen

  • bookstack

    Softwareversionen
    • < 0.30.4: Betroffen

    Keine Korrektur veröffentlicht

  • ssddanbrown/bookstack Packagist

    Softwareversionen
    • 0.7.2
    • V0.7.5
    • v0.10.0
    • v0.11.0
    • v0.11.1
    • v0.11.2
    • v0.12.0
    • v0.12.1
    • v0.12.2
    • v0.13.0
    • v0.13.1
    • v0.14.0
    • v0.14.1
    • v0.14.2
    • v0.14.3
    • v0.15.0
    • v0.15.1
    • v0.15.2
    • v0.15.3
    • v0.16.0
    • v0.16.1
    • v0.16.2
    • v0.16.3
    • v0.17.0
    • v0.17.1
    • v0.17.2
    • v0.17.3
    • v0.17.4
    • v0.18.0
    • v0.18.1
    • v0.18.2
    • v0.18.3
    • v0.18.4
    • v0.18.5
    • v0.19.0
    • v0.20.0
    • v0.20.1
    • v0.20.2
    • v0.20.3
    • v0.21.0
    • v0.22.0
    • v0.23.0
    • v0.23.1
    • v0.23.2
    • v0.24.0
    • v0.24.1
    • v0.24.2
    • v0.24.3
    • v0.25.0
    • v0.25.1
    • v0.25.2
    • v0.25.3
    • v0.25.4
    • v0.25.5
    • v0.26.0
    • v0.26.1
    • v0.26.2
    • v0.26.3
    • v0.26.4
    • v0.27
    • v0.27.1
    • v0.27.2
    • v0.27.3
    • v0.27.4
    • v0.27.5
    • v0.28.0
    • v0.28.1
    • v0.28.2
    • v0.28.3
    • v0.29.0
    • v0.29.1
    • v0.29.2
    • v0.29.3
    • v0.30.0
    • v0.30.1
    • v0.30.2
    • v0.30.3
    • v0.5.0
    • v0.6.0
    • v0.6.1
    • v0.6.2
    • v0.6.3
    • v0.7.0
    • v0.7.3
    • v0.7.4
    • v0.7.6
    • v0.8.0
    • v0.8.1
    • v0.8.2
    • v0.9.0
    • v0.9.1
    • v0.9.2
    • v0.9.3
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 0.30.4

    Auf 0.30.4 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →