p PatchFirst

PatchFirst · Aktuelle Sicherheitslücken

Sicherheitslücken in ssddanbrown/bookstack

In den letzten 30 Tagen veröffentlichte Sicherheitslücken für ssddanbrown/bookstack: 0. Davon im KEV-Katalog: 0.

Sicherheitslücken filtern
Filter zurücksetzen

Sicherheitslücken: 10

  1. CVE-2020-26211

    Hoch · CVSS 7.7EPSS 1,1%Korrektur verfügbar

    Cross-Site Scripting in BookStack

    In BookStack before version 0.30.4, a user with permissions to edit a page could insert JavaScript code through the use of `javascript:` URIs within a link or form which would run, within the context of the current page, when clicked or submitted. Additionally, a user with permissions to edit a page could insert a particular meta tag which could be used to silently redirect users to a alternative location upon visit of a page. Dangerous content may remain in the database but will be removed before being displayed on a page. If you think this could have been exploited the linked advisory provides a SQL query to test. As a workaround without up

    • Auf 0.30.4 aktualisieren
    Veröffentlicht Aktualisiert
  2. CVE-2020-11055

    Mittel · CVSS 6.3EPSS 0,78%Korrektur verfügbar

    Cross-site Scripting in BookStack

    In BookStack greater than or equal to 0.18.0 and less than 0.29.2, there is an XSS vulnerability in comment creation. A user with permission to create comments could POST HTML directly to the system to be saved in a comment, which would then be executed/displayed to others users viewing the comment. Through this vulnerability custom JavaScript code could be injected and therefore ran on other user machines. This most impacts scenarios where not-trusted users are given permission to create comments. This has been fixed in 0.29.2.

    • Auf 0.29.2 aktualisieren
    Veröffentlicht Aktualisiert
  3. CVE-2020-5256

    Hoch · CVSS 7.9EPSS 1,97%Korrektur verfügbar

    Remote Code Execution Through Image Uploads in BookStack

    BookStack before version 0.25.5 has a vulnerability where a user could upload PHP files through image upload functions, which would allow them to execute code on the host system remotely. They would then have the permissions of the PHP process. This most impacts scenarios where non-trusted users are given permission to upload images in any area of the application. The issue was addressed in a series of patches in versions 0.25.3, 0.25.4 and 0.25.5. Users should upgrade to at least v0.25.5 to avoid this vulnerability.

    • Auf 0.25.5 aktualisieren
    Veröffentlicht Aktualisiert

Prüfen Sie Ihren Server

Gleichen Sie Ihren installierten Stack und seine Versionen mit den aktuellen Sicherheitsmeldungen ab.

Prüfen Sie Ihren Server →